-
Notifications
You must be signed in to change notification settings - Fork 1
/
Copy pathJavaLoopsMultipleof2.java
69 lines (49 loc) · 1.07 KB
/
JavaLoopsMultipleof2.java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
/*
Objective
In this challenge, we're going to use loops to help us do some simple math.
Task
Given an integer,N
10, print its first multiples. Each multiple Nxi (where 1<=i<=10
) should be printed on a new line in the form: N x i = result.
Input Format
A single integer,
.
Constraints
2<=N<=20
Output Format
Print 10
lines of output; each line (where ) contains the of result of Nxi
in the form:
N x i = result.
Sample Input
2
Sample Output
2 x 1 = 2
2 x 2 = 4
2 x 3 = 6
2 x 4 = 8
2 x 5 = 10
2 x 6 = 12
2 x 7 = 14
2 x 8 = 16
2 x 9 = 18
2 x 10 = 20
*/
import java.io.*;
import java.math.*;
import java.security.*;
import java.text.*;
import java.util.*;
import java.util.concurrent.*;
import java.util.regex.*;
public class Solution {
private static final Scanner scanner = new Scanner(System.in);
public static void main(String[] args) {
int N = scanner.nextInt();
scanner.skip("(\r\n|[\n\r\u2028\u2029\u0085])?");
for (int i=1;i<=10;i++){
System.out.println(N + " x "+ i +" = " + N*i);
}
scanner.close();
}
}