Skip to content
Browse files

add prerequisites and solve some problems when install stellar5

  • Loading branch information...
1 parent 46b25ba commit 4638be6b4cf823c5949c39d72a2fb7fd3c29b732 yunpeng committed Apr 9, 2013
Showing with 21 additions and 0 deletions.
  1. +21 −0 README.md
View
21 README.md
@@ -4,6 +4,15 @@ stellar5
An IDE totally based on HTML5 technologies integrating online and offline development experience
+Prerequisites
+------------
+Before you install the stellar5, you'll need to make sure your machine complies with the following prerquisites:
+1. The node version should be >= 0.7.12 and I strongly recommend that you use [nvm](https://github.com/creationix/nvm) to install the node.
+2. You should install the 'now','http-proxy','connect' before you run the install.sh at the stellar5 directory like following:
+
+ npm install now http-proxy connect
+
+
Installation
------------
Linux:
@@ -13,6 +22,17 @@ other OS:
Please see install.sh for the steps
+Troubleshooting
+---------------
+If you encounter a problem when running install.sh, you can try to fix it as follows:
+
+
+ cd stellar5/third_party/web-simulator
+
+
+and change the first line of the configure file as : sudo npm install -g jake jshint csslint uglify-js
+
+
Running
-------
* native mode:
@@ -21,3 +41,4 @@ Running
* cloud mode:
./start_server.sh
+

0 comments on commit 4638be6

Please sign in to comment.
Something went wrong with that request. Please try again.