Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

OpenMQTTGateway does not reconnect to mqtt broker #398

Closed
Aggebitter opened this issue May 5, 2019 · 3 comments

Comments

Projects
None yet
2 participants
@Aggebitter
Copy link

commented May 5, 2019

When rebooting mqtt brooker OpenMQTTGateway does not reconnect to my Mosquitto broker.
as it uses QoS 0 (fire and forget) there is no way for it to detect that the broker is down.

Could sys messages be QoS 1 (home/OpenMQTTGateway/SYStoMQTT) and if no ack response just do a reconnect to the broker ?

// Agge

@1technophile

This comment has been minimized.

Copy link
Owner

commented May 15, 2019

I'm not reproducing this issue,

could you please follow the issue template by giving more details on, board used, gateways activated, arduino ide env, board manager version, mosquitto version ...

@1technophile

This comment has been minimized.

Copy link
Owner

commented May 18, 2019

Reproduced if the broker is stopped a long time (several minutes)

@1technophile 1technophile added the bug label May 18, 2019

@1technophile 1technophile added this to the V0.9.2 milestone May 18, 2019

1technophile added a commit that referenced this issue May 27, 2019

Enable auto reconnection to the broker if connection is lost more tha…
…n 30s

#378
#398
by reseting the board instead of going to setup function
@1technophile

This comment has been minimized.

Copy link
Owner

commented May 30, 2019

solved in dev branch

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.