Skip to content

Importing an LDIF from locations other than the LDIF directory fails  #4280

Description

@389-ds-bot

Cloned from Pagure issue: https://pagure.io/389-ds-base/issue/51227

  • Created at 2020-08-03 11:32:48 by mmuehlfeldrh
  • Closed at 2020-08-06 17:49:11 as duplicate
  • Assigned to nobody

Issue Description

If you try to import an LDIF from a directory other than /var/lib/dirsrv/slapd-instance_name/ldif/, the import fails with "No such file or directory".

Package Version and Platform

389-ds-base-1.4.3.10-1.module+el8dsrv+7006+9b1e3ef3.x86_64

Steps to reproduce

  1. Create an LDIF file, for example, /tmp/example.ldif
  2. Make sure that dirsrv is able to read the file (chown dirsrv /tmp/example.ldif ; chmod 644 /tmp/example.ldif)
  3. Try to import the file.

Actual results

dsconf -D "cn=Directory Manager" ldap://server.example.com backend import userRoot  /tmp/example.ldif 
Enter password for cn=Directory Manager on ldap://server.example.com: 
Error: Import task failed
-------------------------
Beginning import job...
Index buffering enabled with bucket size 17
Could not open LDIF file "/tmp/example.ldif", errno 2 (No such file or directory)
Thread monitoring returned: -23

Aborting all Import threads...
Import threads aborted.
Closing files...
Import failed.

Expected results

Import should succeed.

Additional information

The same works on RHEL 8.2 (389-ds-base-1.4.2.12-2.module+el8dsrv+6428+6e54c518.x86_64).

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions