Skip to content
Browse files

upgraded to Grails 2.1.0

  • Loading branch information...
1 parent 11a2e49 commit 8172b5adc47bf85e3a62c6b8320a6805f81f86df @4np committed Jul 19, 2012
Showing with 51 additions and 48 deletions.
  1. +1 −0 .gitignore
  2. +7 −7 UploadrGrailsPlugin.groovy
  3. +2 −2 application.properties
  4. +39 −39 grails-app/conf/BuildConfig.groovy
  5. +2 −0 grails-app/conf/Config.groovy
View
1 .gitignore
@@ -5,6 +5,7 @@
eclipse
stacktrace.log
target
+out
/plugins
/web-app/plugins
/web-app/WEB-INF/classes
View
14 UploadrGrailsPlugin.groovy
@@ -19,22 +19,22 @@
* $Date$
*/
class UploadrGrailsPlugin {
- def version = "0.5.11"
+ def version = "0.5.11"
def grailsVersion = "1.3.7 > *"
def dependsOn = [jquery: "1.4 > *", jqueryUi: "1.8 > *", modernizr: "1.7.2 > *", resources: "1.0 > *"]
def pluginExcludes = [
"grails-app/views/error.gsp"
]
- def author = "Jeroen Wesbeek"
+ def author = "Jeroen Wesbeek"
def authorEmail = "work@osx.eu"
- def title = "A HTML5 drag and drop multi-file upload plugin"
+ def title = "A HTML5 drag and drop multi-file upload plugin"
def description = '''\\
A HTML5 drag and drop multi-file upload plugin
'''
- def documentation = "https://github.com/4np/grails-uploadr/blob/master/README.md"
- def license = "APACHE"
- def issueManagement = [ system: "github", url: "https://github.com/4np/grails-uploadr/issues" ]
- def scm = [ url: "https://github.com/4np/grails-uploadr" ]
+ def documentation = "https://github.com/4np/grails-uploadr/blob/master/README.md"
+ def license = "APACHE"
+ def issueManagement = [ system: "github", url: "https://github.com/4np/grails-uploadr/issues" ]
+ def scm = [ url: "https://github.com/4np/grails-uploadr" ]
// Extra (optional) plugin metadata
View
4 application.properties
@@ -1,4 +1,4 @@
#Grails Metadata file
-#Tue Jun 26 17:05:15 CEST 2012
-app.grails.version=2.0.4
+#Thu Jul 19 14:40:57 CEST 2012
+app.grails.version=2.1.0
app.name=uploadr
View
78 grails-app/conf/BuildConfig.groovy
@@ -5,48 +5,48 @@ grails.project.target.level = 1.6
//grails.project.war.file = "target/${appName}-${appVersion}.war"
grails.project.dependency.resolution = {
- // inherit Grails' default dependencies
- inherits("global") {
- // uncomment to disable ehcache
- // excludes 'ehcache'
- }
- log "warn" // log level of Ivy resolver, either 'error', 'warn', 'info', 'debug' or 'verbose'
- repositories {
- grailsCentral()
- grailsRepo "http://grails.org/plugins"
+ // inherit Grails' default dependencies
+ inherits("global") {
+ // uncomment to disable ehcache
+ // excludes 'ehcache'
+ }
+ log "warn" // log level of Ivy resolver, either 'error', 'warn', 'info', 'debug' or 'verbose'
+ repositories {
+ grailsCentral()
+ grailsRepo "http://grails.org/plugins"
- // uncomment the below to enable remote dependency resolution
- // from public Maven repositories
- //mavenCentral()
- //mavenLocal()
- //mavenRepo "http://snapshots.repository.codehaus.org"
- //mavenRepo "http://repository.codehaus.org"
- //mavenRepo "http://download.java.net/maven/2/"
- //mavenRepo "http://repository.jboss.com/maven2/"
- }
- dependencies {
- // specify dependencies here under either 'build', 'compile', 'runtime', 'test' or 'provided' scopes eg.
+ // uncomment the below to enable remote dependency resolution
+ // from public Maven repositories
+ //mavenCentral()
+ //mavenLocal()
+ //mavenRepo "http://snapshots.repository.codehaus.org"
+ //mavenRepo "http://repository.codehaus.org"
+ //mavenRepo "http://download.java.net/maven/2/"
+ //mavenRepo "http://repository.jboss.com/maven2/"
+ }
+ dependencies {
+ // specify dependencies here under either 'build', 'compile', 'runtime', 'test' or 'provided' scopes eg.
- // runtime 'mysql:mysql-connector-java:5.1.5'
- }
+ // runtime 'mysql:mysql-connector-java:5.1.5'
+ }
- plugins {
- build(":tomcat:$grailsVersion",
- ":release:latest.integration",
- ":rest-client-builder:latest.integration") {
- // plugin only plugin, should not be transitive to the application
- export = false
- }
+ plugins {
+ build(":tomcat:$grailsVersion",
+ ":release:latest.integration",
+ ":rest-client-builder:latest.integration") {
+ // plugin only plugin, should not be transitive to the application
+ export = false
+ }
- compile(":resources:latest.integration") {
- export = false
- }
+ compile(":resources:latest.integration",
+ ":hibernate:$grailsVersion") {
+ export = false
+ }
- runtime(":jquery:latest.integration",
- ":jquery-ui:latest.integration",
- ":modernizr:latest.integration") {
- export = false
- }
-
- }
+ runtime(":jquery:latest.integration",
+ ":jquery-ui:latest.integration",
+ ":modernizr:latest.integration") {
+ export = false
+ }
+ }
}
View
2 grails-app/conf/Config.groovy
@@ -22,3 +22,5 @@ log4j = {
warn 'org.mortbay.log'
}
+grails.views.default.codec="none" // none, html, base64
+grails.views.gsp.encoding="UTF-8"

0 comments on commit 8172b5a

Please sign in to comment.
Something went wrong with that request. Please try again.