Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add support for Plone 5.2 #94

Merged
merged 16 commits into from Nov 6, 2019

Conversation

@buchi
Copy link
Member

buchi commented Nov 1, 2019

  • Add support for Plone 5.2.
  • Make Traversal and Mechanize drivers optional as the underlying libraries are
    no longer available in Zope 4.
  • No longer use plone.formwidget.autocomplete and plone.formwidget.contenttree
    in tests with Plone 5 and later.
  • Implement AjaxSelectWidget and improve RelatedItemsWidget.
  • Modernize z3c form used in tests by using directives to setup widgets and
    removing form wrapper.

Python 3 support comes in a separate PR.

@buchi buchi force-pushed the plone52 branch from 4fb2145 to 204eebb Nov 2, 2019
@buchi buchi requested a review from jone Nov 4, 2019
@jone
jone approved these changes Nov 5, 2019
Copy link
Member

jone left a comment

Thank you! Looks clean and nice 👍

@buchi buchi merged commit 20a62a0 into master Nov 6, 2019
3 checks passed
3 checks passed
CI Governor: test-plone-4.3.x.cfg Task #462878 succeeded
Details
CI Governor: test-plone-5.1.x.cfg Task #462879 succeeded
Details
CI Governor: test-plone-5.2.x.cfg Task #462880 succeeded
Details
@buchi buchi deleted the plone52 branch Nov 6, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.