Audio Quality Problem #31

Closed
lukaseppler opened this Issue Jul 7, 2011 · 9 comments

Comments

Projects
None yet
6 participants
@lukaseppler

In many calls I get the other party complaining that the audio is jittered. I can hear them well. Since Telephone has little configuration (which I like) I don't know where to start looking (which I like less). My SIP provider tells me to use uLaw (G711a) for transport, which I can't verify.

Where can I start?

@lukaseppler

This comment has been minimized.

Show comment Hide comment
@lukaseppler

lukaseppler Jul 7, 2011

BTW, the problem is on Telephone's side - I'm using a SNOM desktop phone too and that doesn't have the problem.

BTW, the problem is on Telephone's side - I'm using a SNOM desktop phone too and that doesn't have the problem.

@narrowtux

This comment has been minimized.

Show comment Hide comment
@narrowtux

narrowtux Jun 25, 2012

I confirm that the audio quality is bad when you're connecting to a Fritz!Box 7270.
Also, I can't hear the other party speaking.

I confirm that the audio quality is bad when you're connecting to a Fritz!Box 7270.
Also, I can't hear the other party speaking.

@njt1982

This comment has been minimized.

Show comment Hide comment
@njt1982

njt1982 Jun 24, 2014

I on an EE Brightbox in the UK and get poor audio with this app. Other VOIP apps are ok (but have horrendus UI's) and my iPhone VOIP app is fine, so its not network.

It might be a codec choice - what is supported and is there any way to set priority?

njt1982 commented Jun 24, 2014

I on an EE Brightbox in the UK and get poor audio with this app. Other VOIP apps are ok (but have horrendus UI's) and my iPhone VOIP app is fine, so its not network.

It might be a codec choice - what is supported and is there any way to set priority?

@fulldecent

This comment has been minimized.

Show comment Hide comment
@fulldecent

fulldecent Dec 8, 2014

Hello, there have been several releases of Telephone since this issue was created. Could you please download and run the latest version to confirm this issue still exists.

Sorry for the template response, just trying to clean up and close old issues here.

Hello, there have been several releases of Telephone since this issue was created. Could you please download and run the latest version to confirm this issue still exists.

Sorry for the template response, just trying to clean up and close old issues here.

@njt1982

This comment has been minimized.

Show comment Hide comment
@njt1982

njt1982 Dec 8, 2014

Is there a new tagged release to check or do we have to compile master ourselves?

On 8 Dec 2014, at 14:50, William Entriken notifications@github.com wrote:

Hello, there have been several releases of Telephone since this issue was created. Could you please download and run the latest version to confirm this issue still exists.

Sorry for the template response, just trying to clean up and close old issues here.


Reply to this email directly or view it on GitHub.

njt1982 commented Dec 8, 2014

Is there a new tagged release to check or do we have to compile master ourselves?

On 8 Dec 2014, at 14:50, William Entriken notifications@github.com wrote:

Hello, there have been several releases of Telephone since this issue was created. Could you please download and run the latest version to confirm this issue still exists.

Sorry for the template response, just trying to clean up and close old issues here.


Reply to this email directly or view it on GitHub.

@fulldecent

This comment has been minimized.

Show comment Hide comment
@fulldecent

fulldecent Dec 8, 2014

Yes and yes, please compile from the tagged release https://github.com/eofster/Telephone/releases/tag/1.1.4

Yes and yes, please compile from the tagged release https://github.com/eofster/Telephone/releases/tag/1.1.4

@rmm5t

This comment has been minimized.

Show comment Hide comment
@rmm5t

rmm5t Apr 2, 2015

I still get complaints from the other party about voice quality issues. I don't have this issue with anything else on the same network. I even have a Polycom phone that I've tried with great quality. There's something wrong with Telephone.app here.

rmm5t commented Apr 2, 2015

I still get complaints from the other party about voice quality issues. I don't have this issue with anything else on the same network. I even have a Polycom phone that I've tried with great quality. There's something wrong with Telephone.app here.

@eofster

This comment has been minimized.

Show comment Hide comment
@eofster

eofster Mar 25, 2016

Owner

Voice quality is a complex problem. I suspect that this issue has gathered several independent cases of the problem. I would start with checking the “Use only G.711 codec” checkbox in Telephone’s Sound preferences. This should help in case of using FritzBox (because it has G.722 codec incompatibility) and in case when the provider explicitly asks to use G.711 codec.

Owner

eofster commented Mar 25, 2016

Voice quality is a complex problem. I suspect that this issue has gathered several independent cases of the problem. I would start with checking the “Use only G.711 codec” checkbox in Telephone’s Sound preferences. This should help in case of using FritzBox (because it has G.722 codec incompatibility) and in case when the provider explicitly asks to use G.711 codec.

@eofster

This comment has been minimized.

Show comment Hide comment
@eofster

eofster Oct 10, 2016

Owner

I believe that audio quality problems are not generic but rather specific to a particular case. If you still have them and wish them to be fixed, please write to the support address to discuss them in more details.

Owner

eofster commented Oct 10, 2016

I believe that audio quality problems are not generic but rather specific to a particular case. If you still have them and wish them to be fixed, please write to the support address to discuss them in more details.

@eofster eofster closed this Oct 10, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment