Permalink
Browse files

Explicitly require the latest versions of Paste/Script/Deploy + Akismet

Although you can probably get away with using an older version, we've
run into one problem and would prefer to avoid them altogether!
  • Loading branch information...
1 parent acd3db3 commit d375ee49527f6c51a65053b9ed26f2be7a91d807 @natedub natedub committed with anthonyt May 5, 2010
Showing with 4 additions and 5 deletions.
  1. +4 −5 setup.py
View
@@ -16,14 +16,17 @@
'repoze.what-pylons == 1.0',
'repoze.what-quickstart',
'repoze.tm2 == 1.0a5',
+ 'Paste == 1.7.3.1',
+ 'PasteDeploy == 1.3.3',
+ 'PasteScript == 1.7.3',
'ToscaWidgets == 0.9.9',
'tw.dynforms',
'zope.sqlalchemy == 0.4',
'MySQL-python >= 1.2.2',
'BeautifulSoup == 3.0.7a',
# We monkeypatch this version of BeautifulSoup in mediacore.__init__
# Patch pending: https://bugs.launchpad.net/beautifulsoup/+bug/397997
- 'akismet',
+ 'akismet == 0.2.0',
]
# PIL has some weird packaging issues (because its been around forever).
@@ -57,9 +60,6 @@
],
install_requires=install_requires,
- setup_requires=[
- 'PasteScript >= 1.6.3'
- ],
paster_plugins=[
'PasteScript',
'Pylons',
@@ -68,7 +68,6 @@
test_suite='nose.collector',
tests_require=[
'WebTest',
- 'BeautifulSoup',
],
packages=find_packages(exclude=['ez_setup']),

0 comments on commit d375ee4

Please sign in to comment.