Permalink
Browse files

don't give an error if you still didn't install requirements.

  • Loading branch information...
1 parent 9fad734 commit 2a78a27cc79c170792fd150bb9313462c15490dd @gkmngrgn gkmngrgn committed May 6, 2013
Showing with 8 additions and 3 deletions.
  1. +8 −3 colorific/__init__.py
View
@@ -21,6 +21,11 @@ def get_version():
__version__ = get_version()
-# import palette modules for backward compatilibity
-from .palette import *
-from .config import *
+# import palette modules for backward compatilibity.
+try:
+ from .palette import *
+ from .config import *
+
+except ImportError:
+ # you should install requirements, see requirements.pip file.
+ pass

0 comments on commit 2a78a27

Please sign in to comment.