New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

UAV issue #426

Open
ccgmatt76 opened this Issue Aug 3, 2016 · 27 comments

Comments

Projects
None yet
4 participants
@ccgmatt76

ccgmatt76 commented Aug 3, 2016

Hi Rev

The Falcon UAV can't be reconnected after server restart and taking it from garage, any idea's ?

Regards

@Gigatek1

This comment has been minimized.

Contributor

Gigatek1 commented Aug 3, 2016

Oh good you found the issue. I was going to test it but probably wouldn't have thought of the restart.
http://www.a3armory.com/forum/thread-743-post-5395.html
I wonder if this has to do with the DLC block. Does this affect the Fenghuang or any other UAV's?

@ccgmatt76

This comment has been minimized.

ccgmatt76 commented Aug 3, 2016

Not 100% sure I'd need to test them, also another issue players are reporting is the inability to use the AV feed.

@AgentRev

This comment has been minimized.

Member

AgentRev commented Aug 3, 2016

The AV feed is force-closed automatically because of quadcopter thermal abuse, as observed by Giga. This can be controlled via A3W_disableUavFeed

@biabock

This comment has been minimized.

biabock commented Aug 3, 2016

It's not about the main topic, but about gigatek post (and this one: http://forums.a3wasteland.com/index.php?topic=2630)
This is a real thing, the UAV_Control addon dont worth much, since its very easy to steal not owned UAVs

I realize that you guys dont know how this "uav hacking" works, so i made a video:
https://youtu.be/ipwhkLgyGtg (btw i recorded that at a3armory xD)
all you need to is spam the arrow key :)

i made this simple fix: biabock/ArmA3_Wasteland.Tanoa@d7e47e9
(idk if this is the best way, but works)

@AgentRev

This comment has been minimized.

Member

AgentRev commented Aug 3, 2016

oh so they're breaking out the timer... nice find

@AgentRev

This comment has been minimized.

Member

AgentRev commented Aug 3, 2016

it should be noted that this would never have been a problem if BIS had implemented fucking UAV event handlers like they're been asked 100+ times 😏

@Gigatek1

This comment has been minimized.

Contributor

Gigatek1 commented Aug 3, 2016

I wouldn't be surprised if this has been happening for awhile. "UAV hacking" does seem like a meme now. At least for A3W. Nice find biabock.

@AgentRev

This comment has been minimized.

Member

AgentRev commented Aug 4, 2016

fixed glitch: 79d313e

as for the original issue, I think Giga found the problem, people need to buy the DLC. best I can do is add a warning for unexpected behavior without DLC purchased.

@AgentRev

This comment has been minimized.

Member

AgentRev commented Aug 4, 2016

although in case of parking retrieve I could try to attempt connection to the player.

@Gigatek1

This comment has been minimized.

Contributor

Gigatek1 commented Aug 4, 2016

I'm running Stratis on my test server and I have 5 saved UAV's. Only 1 (the same one each time) will not load AI at restart. It's 1 of 3 Fenghuang's. Agent you should check this out. I don't see any difference in the database. I think once we find out what the variable with that one UAV, we will see the problem.

@AgentRev

This comment has been minimized.

Member

AgentRev commented Aug 4, 2016

well, just post the contents of the Variables field...

@Gigatek1

This comment has been minimized.

Contributor

Gigatek1 commented Aug 4, 2016

Its the first O_T_UAV_04_CAS_F I bought

/*!40000 ALTER TABLE `servervehicles` DISABLE KEYS */;
INSERT INTO `servervehicles` (`ID`, `ServerID`, `MapID`, `CreationDate`, `LastUsed`, `OwnerUID`, `Parked`, `LockState`, `Class`, `Position`, `Direction`, `Velocity`, `Flying`, `Damage`, `Fuel`, `HitPoints`, `Variables`, `Textures`, `Weapons`, `Magazines`, `Items`, `Backpacks`, `TurretMagazines`, `TurretMagazines2`, `TurretMagazines3`, `AmmoCargo`, `FuelCargo`, `RepairCargo`) VALUES
    (4, 2, 1, '2016-08-03 19:26:34', '2016-08-03 19:26:34', '"76561197965853420"', 0, 1, '"O_T_UAV_04_CAS_F"', '["1863.488647","5752.482422","1.546372"]', '[[-0.996582,-0.0825047,-0.00415039],[-0.00416325,-1.62257e-005,0.999991]]', '[0,0,0]', 0, 0, 1, '[["HitHull",0],["HitTurret",0],["HitGun",0]]', '[["A3W_purchasedVehicle",true],["uavSide","EAST"],["ownerName",[84,111,119,108,101,121]]]', '[]', '[]', '[]', '[]', '[]', '[]', '[["120Rnd_CMFlare_Chaff_Magazine",[-1],120],["4Rnd_LG_Jian",[0],2],["Laserbatteries",[0],1]]', '[]', 0, 0, 0),
    (6, 2, 1, '2016-08-03 19:33:58', '2016-08-03 20:06:37', '"76561197965853420"', 0, 1, '"O_T_UAV_04_CAS_F"', '["1872.488892","5747.471191","1.545974"]', '[[-0.996399,-0.0846872,-0.00415039],[-0.00416262,-3.21672e-005,0.999991]]', '[0,0,0]', 0, 0, 1, '[["HitHull",0],["HitTurret",0],["HitGun",0]]', '[["A3W_purchasedVehicle",true],["uavSide","GUER"],["ownerName",[84,111,119,108,101,121]]]', '[]', '[]', '[]', '[]', '[]', '[]', '[["120Rnd_CMFlare_Chaff_Magazine",[-1],120],["4Rnd_LG_Jian",[0],2],["Laserbatteries",[0],1]]', '[]', 0, 0, 0),
    (7, 2, 1, '2016-08-03 19:37:31', '2016-08-03 20:03:50', '"76561197965853420"', 0, 1, '"I_UAV_02_F"', '["1868.477661","5761.487305","1.549327"]', '[[-0.996277,-0.0858455,-0.00793457],[-0.00728879,-0.00783343,0.999943]]', '[0,0,0]', 0, 0, 1, '[["HitHull",0],["HitTurret",0],["HitGun",0]]', '[["A3W_purchasedVehicle",true],["uavSide","GUER"],["ownerName",[84,111,119,108,101,121]]]', '[]', '[]', '[]', '[]', '[]', '[]', '[["120Rnd_CMFlare_Chaff_Magazine",[-1],120],["Laserbatteries",[0],1],["2Rnd_LG_scalpel",[0],2]]', '[]', 0, 0, 0),
    (8, 2, 1, '2016-08-03 20:07:06', '2016-08-03 20:07:06', '"76561197965853420"', 0, 1, '"O_T_UAV_04_CAS_F"', '["1858.495239","5743.494629","1.544737"]', '[[-0.996198,-0.0871131,-0.000734834],[-0.00058944,-0.00169475,0.999998]]', '[0,0,0]', 0, 0, 1, '[["HitHull",0],["HitTurret",0],["HitGun",0]]', '[["A3W_purchasedVehicle",true],["uavSide","GUER"],["ownerName",[84,111,119,108,101,121]]]', '[]', '[]', '[]', '[]', '[]', '[]', '[["120Rnd_CMFlare_Chaff_Magazine",[-1],120],["4Rnd_LG_Jian",[0],2],["Laserbatteries",[0],1]]', '[]', 0, 0, 0),
    (9, 2, 1, '2016-08-03 20:14:28', '2016-08-03 20:14:28', '"76561197965853420"', 0, 1, '"B_T_UAV_03_F"', '["1886.463257","5729.459473","1.535426"]', '[[0.939923,-0.340741,0.0209921],[-0.0216403,0.00189857,0.999764]]', '[-0.218282,0.0870598,-0.145969]', 0, 0, 1, '[["HitFuel",0],["HitHull",0],["HitEngine",0],["HitAvionics",0],["HitHRotor",0],["HitVRotor",0],["HitEngine1",0],["HitEngine2",0],["HitMissiles",0],["HitRGlass",0],["HitLGlass",0],["HitEngine3",0],["HitWinch",0],["HitTransmission",0],["HitGlass1",0],["HitGlass2",0],["HitGlass3",0],["HitGlass4",0],["HitGlass5",0],["HitGlass6",0],["HitLight",0],["HitHydraulics",0],["HitGear",0],["HitHStabilizerL1",0],["HitHStabilizerR1",0],["HitVStabilizer1",0],["HitTail",0],["HitPitotTube",0],["HitStaticPort",0],["HitStarter1",0],["HitStarter2",0],["HitStarter3",0],["HitTurret",0],["HitGun",0]]', '[["A3W_purchasedVehicle",true],["uavSide","GUER"],["ownerName",[84,111,119,108,101,121]]]', '[]', '[]', '[]', '[]', '[]', '[]', '[["120Rnd_CMFlare_Chaff_Magazine",[-1],120],["6Rnd_LG_scalpel",[0],6],["24Rnd_missiles",[0],24],["Laserbatteries",[0],1]]', '[]', 0, 0, 0);
/*!40000 ALTER TABLE `servervehicles` ENABLE KEYS */;
@Gigatek1

This comment has been minimized.

Contributor

Gigatek1 commented Aug 4, 2016

You're welcome to join the server and join my group if you want to see for yourself. It doesn't even show on the uav panel anyways.

@Gigatek1

This comment has been minimized.

Contributor

Gigatek1 commented Aug 4, 2016

Huh, I just noticed. The first O_T_UAV_04_CAS_F is on side east. That's weird I was never on that side.

@AgentRev

This comment has been minimized.

Member

AgentRev commented Aug 4, 2016

I see 1 Opfor and 4 Indies. Are you saying you are unable to connect to the Opfor one while playing on the Opfor team?

@biabock

This comment has been minimized.

biabock commented Aug 4, 2016

@Gigatek1

This comment has been minimized.

Contributor

Gigatek1 commented Aug 4, 2016

Yeah I think that's the issue, somehow the UAV is going back to its side after a vehicle load. I really don't remember ever joining op4 or even seeing a red square.

@AgentRev

This comment has been minimized.

Member

AgentRev commented Aug 4, 2016

it will never show red squares unless you're actually in Opfor. the icon color only depends on your own side, not the target's.

@Gigatek1

This comment has been minimized.

Contributor

Gigatek1 commented Aug 4, 2016

I know, that's what I mean. I would have noticed a red square instead of a green one (which I saw) if I was mistakenly on op4 when I bought it. Not originally seeing a red square just occurred to me when I joined to make sure it was working when I was on op4, which it was. If I get a report of this, I'll make sure to check the team and ask what team they were on when they bought it.

@AgentRev

This comment has been minimized.

Member

AgentRev commented Aug 4, 2016

looks like I'll have to make the spawn script spam createVehicleCrew every second until it has actually fulfilled its purpose, because obviously BIS did not give a single fuck when they wrote that command.

@Gigatek1

This comment has been minimized.

Contributor

Gigatek1 commented Aug 18, 2016

Report from a player about this.

So earlier today 8-17-16 i logged on to use my UAV helicopter which i had stored the night before in the parking garage and It came out fine, but it wouldn't connect to my uav terminal so that's a whole issue in of itself that i couldn't resolve. So disappointed with my none functioning heli, I stored it again in the parking garage a few hours ago and then logged off. Got back after an hour or so and it's not in the Parking garage anymore. I'm hoping to get my heli back if at all possible.

@Gigatek1

This comment has been minimized.

Contributor

Gigatek1 commented Aug 22, 2016

Another report of this.

So I got a new uav heli. Worked fine until after the restart which AGAIN made me unable to connect to it with my terminal. Literally nothing changed. I haven't died, switched teams or anything. I'm using the exact same terminal. I can't even imagine what the problem is anymore, but this is making me really irritated, especially if i have to spend 60000 every restart.

@AgentRev

This comment has been minimized.

Member

AgentRev commented Aug 24, 2016

@Gigatek1

This comment has been minimized.

Contributor

Gigatek1 commented Aug 24, 2016

Thanks man.

@Gigatek1

This comment has been minimized.

Contributor

Gigatek1 commented Apr 5, 2017

Just got this report about UAV hacking again. Haven't confirmed this or had a response yet about them reporting it or anymore info about it.

Big Tex - Yesterday at 6:09 PM
I think I found a bug, as of 9:00 PM EST I had two drones taken control by someone who didn't not take ownership and was not in my group. I was not able to retake control and the dude destroyed them both.

@AgentRev

This comment has been minimized.

Member

AgentRev commented Apr 5, 2017

need to know which team

@Gigatek1

This comment has been minimized.

Contributor

Gigatek1 commented Apr 5, 2017

Looked up his remote control filter logs and he always plays ind on Tanoa.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment