New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unable to run the dds-tutorial #1

Open
mtourne opened this Issue Oct 22, 2014 · 1 comment

Comments

Projects
None yet
2 participants
@mtourne

mtourne commented Oct 22, 2014

After installing the community edition of opensplice, trying to run the tutorial yields :

$ ./tssub                                                                                                                              

libc++abi.dylib: terminating with uncaught exception of type
  dds::core::InvalidArgumentError:
  dds::core::InvalidArgumentError : Calling ::read at
  /Users/mtourne/dev/opensplice/install/HDE/x86_64.darwin10_clang/include/dcps/C++/isocpp/dds/sub/detail/DataReader.hpp:873
  in dds::sub::LoanedSamples<T>
  dds::sub::detail::DataReader<tutorial::TempSensorType>::read()
  [T = tutorial::TempSensorType]. DDS API call returned
  DDS::RETCODE_BAD_PARAMETER Preceding OpenSplice Error
  Information : Not available - DDS::RETCODE_NO_DATA

zsh: abort      ./tssub
@kydos

This comment has been minimized.

Show comment
Hide comment
@kydos

kydos Oct 22, 2014

Member

Are you using the very last community edition? I'll look into it and keep you posted.

A+

Member

kydos commented Oct 22, 2014

Are you using the very last community edition? I'll look into it and keep you posted.

A+

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment