New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Online compiler can't compile REALTEK RTL8195AM mbed-os-example-wifi #5976

Closed
JanneKiiskila opened this Issue Jan 30, 2018 · 15 comments

Comments

Projects
None yet
5 participants
@JanneKiiskila
Contributor

JanneKiiskila commented Jan 30, 2018

Description

  • Type: Bug
  • Related issue: PR #5611
  • Priority: Major

Bug

Target
RTL8195AM

Toolchain:
on-line compiler

Toolchain version:
?

mbed-cli version:
N/A

mbed-os sha:
mbed-OS 5.7.3

DAPLink version:
N/A

Expected behavior

Realtek RTL8195 AM compiles as per usual with the default mbed_app.json and target selected as RTL8195AM.

Actual behavior

It fails to compile, internal error.

""/extras/mbed_5e5da4a5990b/LPC1768/ARM/LPC1768.sct", line 4 (column 9): Error: L6235E: More than one section matches selector - cannot all be FIRST/LAST." in file "/"

Look for multiple mbed.bld files in your program.

Steps to reproduce

Open on-line compiler.
Select RTL8195AM as the target board
Import mbed-os-example-wifi
Compile

@JanneKiiskila JanneKiiskila referenced this issue Jan 30, 2018

Merged

Realtek RTL8195AM A3 fix #5611

0 of 2 tasks complete
@JanneKiiskila

This comment has been minimized.

Contributor

JanneKiiskila commented Feb 1, 2018

Internal ref: IOTTOO-3170

@thegecko

@0xc0170

This comment has been minimized.

Member

0xc0170 commented Feb 1, 2018

Related #5626 - there was a fix that was propagated to 5.7.3. Looks like the bug is still present.

I can reproduce this with blinky example and 5.7.4

@theotherjimmy

@theotherjimmy

This comment has been minimized.

Contributor

theotherjimmy commented Feb 1, 2018

Huh, I thought that #5626 would get the bug.

@samchuarm

This comment has been minimized.

samchuarm commented Feb 26, 2018

Hi @0xc0170 @theotherjimmy any guidance we could share with Realtek for them to fix this issue would be helpful for Realtek Thanks.

@theotherjimmy

This comment has been minimized.

Contributor

theotherjimmy commented Feb 26, 2018

@samchuarm Thanks for the reminder. It looks like the post build script does not work correctly in the online compiler. I'll take a look.

@theotherjimmy

This comment has been minimized.

Contributor

theotherjimmy commented Feb 26, 2018

I fixed it on partnerbeta. I'm going to send a hotfix to the web team and a PR to Mbed OS in the next 20 min. Let's get this fixed.

@theotherjimmy

This comment has been minimized.

Contributor

theotherjimmy commented Feb 26, 2018

See #6216

@samchuarm

This comment has been minimized.

samchuarm commented Mar 1, 2018

Thanks so much @theotherjimmy

@cmonr cmonr closed this in #6216 Mar 19, 2018

@theotherjimmy theotherjimmy reopened this Apr 5, 2018

@theotherjimmy

This comment has been minimized.

Contributor

theotherjimmy commented Apr 5, 2018

This is not fixed by #6216

@samchuarm

This comment has been minimized.

samchuarm commented Apr 10, 2018

@samchuarm

This comment has been minimized.

samchuarm commented Apr 10, 2018

hi @theotherjimmy it looks like we're still seeing compile fails with online IDE on RTL8195AM target. Anything do you think we need Realtek team to address? Thanks.

@samchuarm

This comment has been minimized.

samchuarm commented Apr 10, 2018

Btw, is it a new issue after merging #6216 ?

@theotherjimmy

This comment has been minimized.

Contributor

theotherjimmy commented Apr 10, 2018

I still need to figure out what's going wrong. It's the post-build script, but I don't know exactly what the problem is yet.

@ciarmcom

This comment has been minimized.

Member

ciarmcom commented Jun 1, 2018

ARM Internal Ref: MBOTRIAGE-277

@theotherjimmy

This comment has been minimized.

Contributor

theotherjimmy commented Jun 18, 2018

@JanneKiiskila @samchuarm Good news: I can't reproduce this anymore! I think this is resolved. Please reopen with steps to reproduce if you find a project that is broken for only the Realtek board.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment