New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

STM32F4 set HSE timeout value to 100ms #4422

Merged
merged 1 commit into from Jun 26, 2017

Conversation

Projects
None yet
7 participants
@jeromecoutant
Contributor

jeromecoutant commented Jun 1, 2017

Description

HSE timeout value is set to 100ms
This is aligned with official ST cube since v1.11.0

This fix #1096

Status

READY

@mr63

This comment has been minimized.

mr63 commented on 476d2e6 Jun 2, 2017

Did you Test this? I made this change in my config file and I still have the 5 Sec. delay before start.

@sg- sg- added the needs: review label Jun 3, 2017

@0xc0170

0xc0170 approved these changes Jun 5, 2017

@0xc0170 0xc0170 added needs: CI and removed needs: review labels Jun 5, 2017

@0xc0170

This comment has been minimized.

Member

0xc0170 commented Jun 5, 2017

/morph test

@mbed-bot

This comment has been minimized.

mbed-bot commented Jun 5, 2017

Result: FAILURE

Your command has finished executing! Here's what you wrote!

/morph test

Output

mbed Build Number: 450

Example Build failed!

@jeromecoutant

This comment has been minimized.

Contributor

jeromecoutant commented Jun 7, 2017

Please restart morph test as error was not linked to the PR

@0xc0170

This comment has been minimized.

Member

0xc0170 commented Jun 9, 2017

Please restart morph test as error was not linked to the PR

Will do after we generate rc2 (lot of PR are in the queue at the moment)

@sad948

This comment has been minimized.

sad948 commented Jun 14, 2017

It does not work for me neither. I am using a NUCLEO-F401RE with default board configuration and I have made the change that you propose in the config file "stm32f4xx_hal_conf.h".

#define HSE_STARTUP_TIMEOUT 100U /*!< Time out for HSE start up, in ms */

#define LSE_STARTUP_TIMEOUT 100U /*!< Time out for LSE start up, in ms */

I have tried with mbed_122 version and it works properly, but, for instance, if I update to mbed_142 or mbed_144 the board does not start to work until 10 seconds.

Is there a way to solve it?

Thanks in advance.

@jeromecoutant

This comment has been minimized.

Contributor

jeromecoutant commented Jun 14, 2017

@sad948
please raise a new issue with the code you are executing
There should be another problem as this patch.
Thx

@sad948

This comment has been minimized.

sad948 commented Jun 15, 2017

@jeromecoutant
The code I am using is the example of the blinking led, but you can try with any other example in the mbed online compiler and the same issue always happens.

#include "mbed.h"

DigitalOut myled(LED1);

int main() {
while(1) {
myled = 1; // LED is ON
wait(0.2); // 200 ms
myled = 0; // LED is OFF
wait(1.0); // 1 sec
}
}

If I download to the board this example with the mbed_122 version it starts to work almost instantly, but when I do it with mbed_142 or mbed_144 it takes 10 seconds to start working.

Is there a way to solve it?

Thanks in advance.

@jeromecoutant

This comment has been minimized.

Contributor

jeromecoutant commented Jun 16, 2017

Is there a way to solve it?

yes, you have to apply this pull request....

@theotherjimmy

This comment has been minimized.

Contributor

theotherjimmy commented Jun 19, 2017

@adbridge @0xc0170 @sg- This is not being ironed into our waffle. It's going to need a re-run of morph test when we have room in the pipeline.

@jeromecoutant

This comment has been minimized.

Contributor

jeromecoutant commented Jun 21, 2017

bump :-)

@0xc0170

This comment has been minimized.

Member

0xc0170 commented Jun 21, 2017

bump :-)

As soon as 5.5.1 CI finished, all needs: CI will be queued

@0xc0170

This comment has been minimized.

Member

0xc0170 commented Jun 26, 2017

/morph test

@mbed-bot

This comment has been minimized.

mbed-bot commented Jun 26, 2017

Result: SUCCESS

Your command has finished executing! Here's what you wrote!

/morph test

Output

mbed Build Number: 633

All builds and test passed!

@0xc0170 0xc0170 added ready for merge and removed needs: CI labels Jun 26, 2017

@theotherjimmy theotherjimmy merged commit fc39ad1 into ARMmbed:master Jun 26, 2017

4 checks passed

Cam-CI uvisor Build & Test Success
Details
ci/morph-test Job has completed
Details
continuous-integration/jenkins/pr-head This commit looks good
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details

@jeromecoutant jeromecoutant deleted the jeromecoutant:PR_F4_HSE_TIMEOUT branch Jun 27, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment