Permalink
Browse files

Fixed compatibility with CMake 2.8.12

  • Loading branch information...
kFYatek committed Jan 9, 2018
1 parent 3d67aab commit de2246ea159d24fb9c5a5fb0d458f8ee306bc99c
Showing with 1 addition and 6 deletions.
  1. +1 −1 test/codegen/CMakeLists.txt
  2. +0 −5 test/integration/CMakeLists.txt
@@ -33,7 +33,7 @@ foreach(CODEGEN_INPUT ${CODEGEN_INPUTS})
list(APPEND CODEGEN_SOURCES "${OUTPUT}")
endforeach()
add_library(codegen_check OBJECT EXCLUDE_FROM_ALL "${CODEGEN_SOURCES}")
add_library(codegen_check OBJECT EXCLUDE_FROM_ALL ${CODEGEN_SOURCES})
set_target_properties(codegen_check PROPERTIES
COMPILE_FLAGS "-Wno-missing-declarations -Wno-unused-variable -Wno-unused-parameter")
@@ -58,11 +58,6 @@ if(NOT MBEDTLS_LIBRARY)
message(FATAL_ERROR "mbed TLS is required for integration tests")
endif()
if(CMAKE_MAJOR_VERSION LESS 3
OR (CMAKE_MAJOR_VERSION EQUAL 3 AND CMAKE_MINOR_VERSION LESS 1))
message(FATAL_ERROR "CMake >=3.1.0 is required to run integration tests")
endif()
set(_MISSING_PYTHON_MSG "If you have it installed on your system, but your cmake version is outdated you could try to restart the process that lead to this error message with: -DPython_ADDITIONAL_VERSIONS=3.x")
if(Python_ADDITIONAL_VERSIONS)

0 comments on commit de2246e

Please sign in to comment.