Skip to content

Making 0.12.1.0 Compilable under GHC 7.6.x ? #75

Closed
adinapoli opened this Issue Feb 14, 2013 · 4 comments

2 participants

@adinapoli

Hello guys, accelerate 0.12.1.0 (the one currently on hackage) depends from ghc-prim == 2., but this creates problem with modern base installation, making everything fail. The fix should be trivial, allow ghc-prim to be >= 2. in the manifest, as you did for 0.13.

Thoughts?

@tmcdonell
Data.Array.Accelerate member

It should be simple enough to make a patch release; I'll investigate. This slipped under the radar because I had intended to make a release for 0.13 before the new year (oops...).

-T

@adinapoli

Not only is it an easy fix, but the 0.13 already works; it's just a matter of releasing the new 0.13 package on Hackage :)

@tmcdonell
Data.Array.Accelerate member

Released! (finally, apologies for the delay)

@tmcdonell tmcdonell closed this May 11, 2013
@adinapoli

Yay!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.