Requirements

Adam edited this page Jul 17, 2016 · 7 revisions

End User requirements

To launch a Duality application, the end user needs the .Net Framework 4.5 on Windows machines, or the equivalent Mono version on non-Windows machines. The actual hardware minimum to launch a Duality application depends on the application itself.

Developer requirements

For developing Duality games, you're going to need a Windows machine - and since Duality doesn't bring its own programming IDE, any source code related activity will require additional software. I'd recommended to use Visual Studio (at least version 2013, Update 3). There is also a Community Version of Visual Studio that is completely free - you don't need any kind of professional version for Duality development.