Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Applied element hiding rules are not visible in filtering log in some cases #1200

Closed
Alex-302 opened this issue Dec 24, 2018 · 3 comments
Closed
Assignees
Labels
Milestone

Comments

@Alex-302
Copy link
Member

@Alex-302 Alex-302 commented Dec 24, 2018

Steps to reproduce

  1. Log in to e.mail.ru

Actual behavior

Applied rule is not shown in filtering log e.mail.ru##div[class^="b-letter"] div.b-rb:has(> div)
After applying the ryle, anti-adblock script obfuscate html tags.

Expected behavior

The rule is visible in the log.

Your environment

  • AdGuard AdBlocker extension version: 2.10.14 / 3.0
  • Environment name and version: Chrome 70
  • Filters you use in AdGuard: Eng(Base), Rus
@ameshkov ameshkov added this to the 3.0 milestone Dec 25, 2018
@maximtop

This comment has been minimized.

Copy link
Contributor

@maximtop maximtop commented Dec 25, 2018

Memo for myself
The extension should check all mutation records if the filtering log is open despite the performance

@maximtop

This comment has been minimized.

Copy link
Contributor

@maximtop maximtop commented Feb 6, 2019

In order to test you can repeat steps described by the topic starter

@Alex-302

This comment has been minimized.

Copy link
Member Author

@Alex-302 Alex-302 commented Feb 6, 2019

That rule is removed. Add it to user filter.

@zzebrum zzebrum closed this Feb 7, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.