Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

A bug with element hiding rule with domains containing `www` #665

Closed
theseanl opened this issue May 2, 2017 · 6 comments
Closed

A bug with element hiding rule with domains containing `www` #665

theseanl opened this issue May 2, 2017 · 6 comments
Assignees
Labels
Bug
Milestone

Comments

@theseanl
Copy link
Contributor

@theseanl theseanl commented May 2, 2017

STR:

  1. Add a rule~www.google.com,google.com##body > div:nth-of-type(1)
  2. Go to https://www.google.com

Expected result: the rule is not injected, and the page is displayed as normal.
Actual result: the page is blank.
This broke a website in https://forum.adguard.com/index.php?threads/cba-pl.21252/

@theseanl theseanl added the Bug label May 2, 2017
@ameshkov

This comment has been minimized.

Copy link
Member

@ameshkov ameshkov commented May 8, 2017

I wonder, do we have the same issue in Windows version?

@theseanl

This comment has been minimized.

Copy link
Contributor Author

@theseanl theseanl commented May 8, 2017

Not on my end.

@ameshkov ameshkov added this to the 2.6 milestone May 8, 2017
atropnikov added a commit that referenced this issue May 16, 2017
atropnikov added a commit that referenced this issue May 17, 2017
A bug with element hiding rule with domains containing `www` #665
@atropnikov atropnikov closed this May 17, 2017
@Alex-302 Alex-302 reopened this Aug 21, 2017
@Alex-302 Alex-302 modified the milestones: 2.7, 2.6 Aug 21, 2017
@Alex-302

This comment has been minimized.

Copy link
Member

@Alex-302 Alex-302 commented Aug 21, 2017

The bug is still exists.
For example:
www.i.ua##body
this rule is applied to i.ua and to some sub-domains:
http://shop.i.ua http://mbox2.i.ua/ - applied
http://perevod.i.ua http://weather.i.ua - not applied

@Mizzick Mizzick self-assigned this Aug 22, 2017
@atropnikov

This comment has been minimized.

Copy link
Member

@atropnikov atropnikov commented Aug 28, 2017

The problem isn't in domains or subdomains. Seems some script on the website, that somehow disables rules in the shadow DOM. I could not find how do they do it. I tried to apply CSS rules with some delay, and everything is OK in this case.

@Alex-302

This comment has been minimized.

Copy link
Member

@Alex-302 Alex-302 commented Aug 28, 2017

@atropnikov strange, but the rule is applied now to that domains. But my question is about domain with www. www.i.ua##body must be applied to www.i.ua only.

@atropnikov

This comment has been minimized.

Copy link
Member

@atropnikov atropnikov commented Aug 29, 2017

Fixed 3da5a9b

@atropnikov atropnikov closed this Aug 29, 2017
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
5 participants
You can’t perform that action at this time.