New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Google Apps stop working with "No network" error #1334

Closed
altokarev opened this Issue Jul 19, 2017 · 20 comments

Comments

Projects
None yet
8 participants
@altokarev
Member

altokarev commented Jul 19, 2017

Expected behavior

No network error while using YouTube app, Facebook Messenger, Adsense and other apps.

Actual behaviour

Apps like Facebook Messenger and Adsense stop working with "No network" error. This is happening even after user whitelisted those apps.

Screenshot:

screenshot_20170716-225025

1182498_logs.zip

Customer ID

1182498

Your environment

  • Adguard version: 2.9.135
  • Adguard filtering mode: VPN
  • Device model: OnePlus 5
  • Android 7.1.1
  • Not rooted
  • No task killer/cleaner apps. No other apps are using VPN. Adguard is whitelisted on the
    battery optimization (Doze).
@altokarev

This comment has been minimized.

Show comment
Hide comment
@altokarev
Member

altokarev commented Jul 19, 2017

There is one more case on our forum. Original thread: https://forum.adguard.com/index.php?threads/youtube-issues.23498/

1599135_logs.zip

@vozersky vozersky added the bug label Jul 20, 2017

@vozersky vozersky added this to the 2.10 milestone Jul 20, 2017

@ameshkov ameshkov self-assigned this Jul 21, 2017

@ameshkov

This comment has been minimized.

Show comment
Hide comment
@ameshkov

ameshkov Jul 21, 2017

Member

Got it. I need more logs of this issue, though:
https://kb.adguard.com/en/android/solving-problems/log

Member

ameshkov commented Jul 21, 2017

Got it. I need more logs of this issue, though:
https://kb.adguard.com/en/android/solving-problems/log

@ameshkov ameshkov modified the milestones: 2.9 R2, 2.10 Jul 22, 2017

@ameshkov

This comment has been minimized.

Show comment
Hide comment
@ameshkov

ameshkov Jul 22, 2017

Member

Promoted to P1: Critical, we'll have to release a hotfix for v2.9R2 that will fix the issue.

Member

ameshkov commented Jul 22, 2017

Promoted to P1: Critical, we'll have to release a hotfix for v2.9R2 that will fix the issue.

@ameshkov

This comment has been minimized.

Show comment
Hide comment
@ypetruk

This comment has been minimized.

Show comment
Hide comment
@ypetruk

ypetruk Jul 24, 2017

Logs in the Ticket ID:1601169

ypetruk commented Jul 24, 2017

Logs in the Ticket ID:1601169

@ypetruk

This comment has been minimized.

Show comment
Hide comment
@ypetruk

ypetruk Jul 24, 2017

more logs in Ticket ID: 1594079

ypetruk commented Jul 24, 2017

more logs in Ticket ID: 1594079

@altokarev

This comment has been minimized.

Show comment
Hide comment
@altokarev
Member

altokarev commented Jul 24, 2017

@ameshkov

This comment has been minimized.

Show comment
Hide comment
@ameshkov

ameshkov Jul 24, 2017

Member

@ypetruk @altokarev please ask people to try the latest build: https://adguard.com/apkb

Member

ameshkov commented Jul 24, 2017

@ypetruk @altokarev please ask people to try the latest build: https://adguard.com/apkb

@veronikasav

This comment has been minimized.

Show comment
Hide comment
@veronikasav

veronikasav Jul 25, 2017

Customer feedback:

"So I have downloaded the latest beta and I have updated the filters and it looks that it finally works ok. By the way, maybe it's useful for you to know that the bug didn't allow to pay on Google play. So I'm happy that finally, you have fixed it."

Ticket ID: 1600755

veronikasav commented Jul 25, 2017

Customer feedback:

"So I have downloaded the latest beta and I have updated the filters and it looks that it finally works ok. By the way, maybe it's useful for you to know that the bug didn't allow to pay on Google play. So I'm happy that finally, you have fixed it."

Ticket ID: 1600755

@ypetruk

This comment has been minimized.

Show comment
Hide comment
@ypetruk

ypetruk Jul 25, 2017

the beta is not working either https://adguard.com/apkb
Ticket ID: 1406620

ypetruk commented Jul 25, 2017

the beta is not working either https://adguard.com/apkb
Ticket ID: 1406620

@ameshkov

This comment has been minimized.

Show comment
Hide comment
@ameshkov

ameshkov Jul 25, 2017

Member

Logs?

Member

ameshkov commented Jul 25, 2017

Logs?

@psych

This comment has been minimized.

Show comment
Hide comment
@psych

psych Jul 26, 2017

I am experiencing the same error/problem when using Chrome on Android (using Lineage OS but also happened using stock Android). Any website I navigate to after a certain causes Chrome to display "err_connection_refused" error. Interestingly, it doesn't seem to affect their built in browser on Lineage OS which continues to connect to the internet and does not display the "no internet" error. This also occurs regardless of http/https. Stopping and restarting protection using the green button solves the problem temporarily. I am also on the latest beta as recommended above.

Edit Information was submitted via in app feedback form as directed in prev. thread.

logs attached in Ticket ID: 1602738

psych commented Jul 26, 2017

I am experiencing the same error/problem when using Chrome on Android (using Lineage OS but also happened using stock Android). Any website I navigate to after a certain causes Chrome to display "err_connection_refused" error. Interestingly, it doesn't seem to affect their built in browser on Lineage OS which continues to connect to the internet and does not display the "no internet" error. This also occurs regardless of http/https. Stopping and restarting protection using the green button solves the problem temporarily. I am also on the latest beta as recommended above.

Edit Information was submitted via in app feedback form as directed in prev. thread.

logs attached in Ticket ID: 1602738

@ameshkov

This comment has been minimized.

Show comment
Hide comment
@ameshkov

ameshkov Jul 31, 2017

Member

@psych

using Lineage OS but also happened using stock Android

I've examined the log and this is another issue for sure: #1345

For some unknown reason, Lineage OS starts dropping AG connections after some time. To understand what's going on we need to take a look at the system logs. Here's how to get them:
https://kb.adguard.com/en/android/solving-problems/logcat

Member

ameshkov commented Jul 31, 2017

@psych

using Lineage OS but also happened using stock Android

I've examined the log and this is another issue for sure: #1345

For some unknown reason, Lineage OS starts dropping AG connections after some time. To understand what's going on we need to take a look at the system logs. Here's how to get them:
https://kb.adguard.com/en/android/solving-problems/logcat

@ameshkov ameshkov closed this Jul 31, 2017

@ameshkov ameshkov modified the milestones: 2.10, 2.9 R2 Aug 1, 2017

@ameshkov ameshkov added P2: High and removed P1: Critical labels Aug 1, 2017

@ameshkov ameshkov changed the title from Apps stop working with "No network" error to Google Apps stop working with "No network" error Aug 1, 2017

@ameshkov

This comment has been minimized.

Show comment
Hide comment
@ameshkov

ameshkov Aug 1, 2017

Member

It still happens from time to time. We should temporary remove ||app-measurement.com^ to solve the issue. Uncomment it once the new update goes live.

Member

ameshkov commented Aug 1, 2017

It still happens from time to time. We should temporary remove ||app-measurement.com^ to solve the issue. Uncomment it once the new update goes live.

@ameshkov ameshkov reopened this Aug 1, 2017

@Bohdan-SUP

This comment has been minimized.

Show comment
Hide comment
@Bohdan-SUP

Bohdan-SUP Aug 1, 2017

Member

@ameshkov anything we can suggest in the meantime?

Member

Bohdan-SUP commented Aug 1, 2017

@ameshkov anything we can suggest in the meantime?

@ameshkov

This comment has been minimized.

Show comment
Hide comment
@ameshkov
Member

ameshkov commented Aug 1, 2017

@ameshkov ameshkov modified the milestones: 2.11, 2.10 Sep 7, 2017

@carlylemiii

This comment has been minimized.

Show comment
Hide comment
@carlylemiii

carlylemiii Oct 5, 2017

Not sure if this is the same issue, but the Google Home app won't load anything with HTTPS filtering enabled. There was an update to that app today because of new products, so I'm not sure if it's related or it's always been that way.

Regardless, having AdGuard disabled allows it to work, as does disabling just HTTPS filtering, but as soon as everything is filtered, there's a looping animation that eventually ends in "No connection".

Logs/screenshots:
https://www.dropbox.com/sh/gtd5t6xh97mg1g6/AADUAs4LrfQTpwGsIdlvOViba?dl=0

carlylemiii commented Oct 5, 2017

Not sure if this is the same issue, but the Google Home app won't load anything with HTTPS filtering enabled. There was an update to that app today because of new products, so I'm not sure if it's related or it's always been that way.

Regardless, having AdGuard disabled allows it to work, as does disabling just HTTPS filtering, but as soon as everything is filtered, there's a looping animation that eventually ends in "No connection".

Logs/screenshots:
https://www.dropbox.com/sh/gtd5t6xh97mg1g6/AADUAs4LrfQTpwGsIdlvOViba?dl=0

@ameshkov

This comment has been minimized.

Show comment
Hide comment
@ameshkov

ameshkov Oct 5, 2017

Member

@carlylemiii
Filed a new issue:
#1515

Member

ameshkov commented Oct 5, 2017

@carlylemiii
Filed a new issue:
#1515

@carlylemiii

This comment has been minimized.

Show comment
Hide comment
@carlylemiii

carlylemiii Jan 25, 2018

Google Maps has displayed a "Can't connect to Maps" error probably half a dozen times so far since I've switched over to proxy mode.

adguard_logs_2.10.186_2501_1431.zip

But since it seems you implemented a temporary fix back in August, not sure if it's related.

carlylemiii commented Jan 25, 2018

Google Maps has displayed a "Can't connect to Maps" error probably half a dozen times so far since I've switched over to proxy mode.

adguard_logs_2.10.186_2501_1431.zip

But since it seems you implemented a temporary fix back in August, not sure if it's related.

@ameshkov

This comment has been minimized.

Show comment
Hide comment
@ameshkov

ameshkov Mar 6, 2018

Member

CoreLibs filtering engine is coming soon, closing this issue in favor of the new one: AdguardTeam/CoreLibs#182

Member

ameshkov commented Mar 6, 2018

CoreLibs filtering engine is coming soon, closing this issue in favor of the new one: AdguardTeam/CoreLibs#182

@ameshkov ameshkov closed this Mar 6, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment