Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

AdGuard is not capturing the mobile data usage correctly #1856

Closed
Eugene-Savenko opened this issue May 7, 2018 · 2 comments
Assignees
Labels
Milestone

Comments

@Eugene-Savenko
Copy link
Member

@Eugene-Savenko Eugene-Savenko commented May 7, 2018

The data usage is being assigned to Wi-Fi despite the bug #1665 is closed. The only workaround I found is manually disabling and re-enabling AdGuard or restarting the device. The thing is that for some reason AdGuard believes that I'm still connected to Wi-Fi and assigns traffic stats to the Wi-Fi tab instead of the mobile tab.

Steps to reproduce

  1. I started connected to Wi-Fi and opened Reddit and loaded a few pages. AdGuard filtered it and showed it correctly on the Wi-Fi tab.
  2. Then I turned off Wi-Fi and switched to mobile network. I opened Reddit again and used it a bit. As you can see in the screenshots below no data is shown in the mobile tab. All of it is assigned to the Wi-Fi tab.
Screenshot:

image

Expected behavior

Stats are correctly assigned based on the type of connection

Actual behavior

AdGuard does not understand that the connection has changed which distorts data usage stats

Customer ID

1549733, w/ logs

Your environment

  • Adguard version: 2.12.4
  • Adguard filtering mode: "proxyMode" : true, Manual: false
  • Device model: ONEPLUS A3003
  • Operating system and version: 8.1.0
  • Rooted or not? yes
  • Any other apps that can start VPN/Antiviruses/Cleaners etc. installed? n/a
@ameshkov ameshkov added this to the 2.12 milestone May 7, 2018
@ameshkov

This comment has been minimized.

Copy link
Member

@ameshkov ameshkov commented May 7, 2018

@admitrevskiy examine the logs, search for the connectivity change events there

@admitrevskiy

This comment has been minimized.

Copy link

@admitrevskiy admitrevskiy commented Jun 26, 2018

Resolved

Testing instructions:

  1. Reinstall AG
  2. Connect to WiFi and enable protection
  3. Open N sites in Chrome
  4. Change connection to mobile network
  5. Open N sites in Chrome
  6. Go to Apps Management –> Chrome

Expected result:
Wi-Fi and mobile data should be approximately equal

@vozersky vozersky closed this Jul 31, 2018
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.