Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't export User Filter on Android 8.1.0 #1865

Closed
CHEF-KOCH opened this issue May 10, 2018 · 8 comments
Closed

Can't export User Filter on Android 8.1.0 #1865

CHEF-KOCH opened this issue May 10, 2018 · 8 comments
Assignees
Labels
Milestone

Comments

@CHEF-KOCH
Copy link

@CHEF-KOCH CHEF-KOCH commented May 10, 2018

Steps to reproduce

  1. Install AdGuard 2.11.81
  2. Ensure that AdGuard app has permission to write/read on storage via settings - apps - adguard -permissions -> storage.
  3. Restart the app (if already running)
  4. Create User Filter
  5. Try to export the User Filter list, no matter if internal/external store you get the message Error exporting user rules.
  6. The import of a own filter list partially works, from some folders it doesn't work.

Expected behavior

AdGuard should export the User List on the Internal or external sdcard without any problems as long as the storage isn't special protected or restricted.

Actual behavior

You see an error - Error exporting user rules. The text file with 0 bytes is created.

Customer ID

  • 1863484

Environment

  • Adguard version: 2.11.81 (stable)
  • Adguard filtering mode: VPN + HTTPS filtering on
  • Device model: S5 mini (GM-G800F) test device
  • Security Patch level: April 5, 2018
  • LineageOS API level: llama (9)
  • Operating system and version: LineageOS 8.1 it also happens with Android 9 (P) Dev 1 with a Nexus
  • Rooted or not?: Rooted via Magsik
  • Any other apps that can start VPN/Antiviruses/Cleaners etc. installed?: No.
@ameshkov ameshkov added this to the 2.12 milestone May 10, 2018
@ameshkov

This comment has been minimized.

Copy link
Member

@ameshkov ameshkov commented May 10, 2018

@CHEF-KOCH thank you for reporting it!

@admitrevskiy it appears that the exception is swallowed in the code (see ExportUserRulesTask) so there's nothing useful in the log file.

If you cannot reproduce this issue on your side, prepare a test build with proper exceptions handling and share it here.

@admitrevskiy

This comment has been minimized.

Copy link

@admitrevskiy admitrevskiy commented May 24, 2018

@CHEF-KOCH Hi!
Please install this version: https://uploads.adguard.com/ADwvveo.apk
Go to Settings -> Advanced -> Logging level, set it to "Record everything" and try to export user filter.

@admitrevskiy

This comment has been minimized.

Copy link

@admitrevskiy admitrevskiy commented Jun 15, 2018

@CHEF-KOCH Hi!
Please, send logs from attached version to devteam at adguard.com if your issue is still actual.
In another case let me know if it's not, please

@CHEF-KOCH

This comment has been minimized.

Copy link
Author

@CHEF-KOCH CHEF-KOCH commented Jun 16, 2018

Sorry, I can't get the log, it's always 0 bytes.

Someone else needs to confirm and verify if this issue still exists, I tried the new version + even compiled a newer ROM version but the problem still exists.

@TheHasagi

This comment has been minimized.

Copy link
Contributor

@TheHasagi TheHasagi commented Jun 18, 2018

@CHEF-KOCH

Hello!

Please install the latest nightly version 2.12.60n - https://agrd.io/android_nightly and try to reproduce the issue.

I'm on the Los 15.1 do not have this issue.

@ameshkov

This comment has been minimized.

Copy link
Member

@ameshkov ameshkov commented Jun 18, 2018

Someone else needs to confirm and verify if this issue still exists, I tried the new version + even compiled a newer ROM version but the problem still exists.

Could you please tell us what exact ROM do you use? We'll try using the same then.

@ameshkov

This comment has been minimized.

Copy link
Member

@ameshkov ameshkov commented Jun 18, 2018

On the other hand

Sorry, I can't get the log, it's always 0 bytes.

This must be caused by the very same issue as the export error. It has something to do with the access rights to the external storage..

@admitrevskiy

This comment has been minimized.

Copy link

@admitrevskiy admitrevskiy commented Jun 28, 2018

Testing instructions:

-Reinstall AdGuard
-Deny Storage permission if it was allowed
-Try one of the following operations: Export logs/Export settings/Export user filters/Alternative certificate installation

Expected behavior:

  1. You can't perform above operations until permission was not granted
  2. Information dialog with redirect to the settings appears In case of "Never ask again" checkbox was enabled
@vozersky vozersky closed this Jul 31, 2018
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
5 participants
You can’t perform that action at this time.