Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

AG connecting to a proxy which is not added yet #2543

Closed
zzebrum opened this issue Feb 12, 2019 · 6 comments
Closed

AG connecting to a proxy which is not added yet #2543

zzebrum opened this issue Feb 12, 2019 · 6 comments
Assignees
Labels
Milestone

Comments

@zzebrum
Copy link
Contributor

@zzebrum zzebrum commented Feb 12, 2019

Steps to reproduce

  1. Settings - Network - Proxy settings
  2. enable proxy

Expected behavior

since there is no proxy added, AG should not restart the protection and connect to the nonexistent proxy.

Actual behavior

notification about AG connected to a proxy, protection restarts.

@zzebrum zzebrum added this to the 3.0 milestone Feb 12, 2019
@Revertron

This comment has been minimized.

Copy link
Member

@Revertron Revertron commented Feb 12, 2019

Done.

@zzebrum

This comment has been minimized.

Copy link
Contributor Author

@zzebrum zzebrum commented Feb 13, 2019

  1. Add proxy server
  2. Connect to it
  3. Delete the server from the list

Actual behavior: AG connected to the proxy

Expected behavior: We should handle the situation

@sfionov

This comment has been minimized.

Copy link
Member

@sfionov sfionov commented Feb 13, 2019

Also there is an UI problem:
Size of proxy adding dialog is halved if I switch between apps while filling that dialog.

@aspasskaya

This comment has been minimized.

Copy link
Contributor

@aspasskaya aspasskaya commented Mar 1, 2019

  1. Add proxy server
  2. Connect to it
  3. Delete the server from the list

Expected behavior: Proxy disabled.
Actual behavior:
image

@admitrevskiy

This comment has been minimized.

Copy link

@admitrevskiy admitrevskiy commented Mar 4, 2019

Done.

Testing instructions for QA:
-Reinstall AG
-Try to reproduce the following issues:

@TheHasagi

This comment has been minimized.

Copy link
Contributor

@TheHasagi TheHasagi commented Mar 5, 2019

Fixes should be available with the nearest updates.

@zzebrum zzebrum closed this Mar 14, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
6 participants
You can’t perform that action at this time.