Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error while parsing a style tag with embedded svg #373

Closed
backupmc opened this issue Mar 17, 2016 · 7 comments
Closed

Error while parsing a style tag with embedded svg #373

backupmc opened this issue Mar 17, 2016 · 7 comments
Assignees
Labels
Bug
Milestone

Comments

@backupmc
Copy link

@backupmc backupmc commented Mar 17, 2016

Hi,

The bug is related to a wrong rendering of (at least) the Lifehacker website. You can find more details (and screenshots) in the adguard forum.

http://forum.adguard.com/showthread.php?9655-Troubles-with-Lifehacker-website

Version of the android app: 2.1.359

List of the active filters:
English
Spyware
Social networks widgets
Useful
Mobile phones
EasyList Italy
Liste Fr.

It should be noted that the page isn't rendered correctly just with the advanced/filter mode set to high quality. It works perfectly with both high speed or simplified mode.

best regards,
Paul

@ameshkov ameshkov added the Bug label Mar 18, 2016
@ameshkov ameshkov added this to the 2.5 milestone Mar 18, 2016
@ameshkov ameshkov self-assigned this Mar 18, 2016
@ameshkov ameshkov added the Filtering label Mar 18, 2016
@backupmc

This comment has been minimized.

Copy link
Author

@backupmc backupmc commented Mar 19, 2016

@BooBerry

This comment has been minimized.

Copy link

@BooBerry BooBerry commented Mar 20, 2016

And it happens on kotaku.com as well

http://forum.adguard.com/showthread.php?9740-Kotaku-com-Android

Lifehacker, Gizmodo and Kotaku are all Gawker Media sites. So it's likely all their sites have this issue.

@ameshkov ameshkov changed the title App doesn't work in Lifehacker website Error of parsing style tag with embedded svg Mar 21, 2016
@ameshkov ameshkov changed the title Error of parsing style tag with embedded svg Error while parsing a style tag with embedded svg Mar 21, 2016
@ameshkov

This comment has been minimized.

Copy link
Member

@ameshkov ameshkov commented Mar 21, 2016

There is a complex style on the page:
url('data:image/svg+xml;utf8,<svg width="32" height="24" viewBox="0 0 32 24" xmlns="http://www.w3.org/2000/svg"><title>Group</title>.................

AG parsed thought that embedded SVG is html page code and injected inside it. Hence the page code was broken.

@ameshkov

This comment has been minimized.

Copy link
Member

@ameshkov ameshkov commented Mar 21, 2016

Fixed

@ameshkov ameshkov closed this Mar 21, 2016
@backupmc

This comment has been minimized.

Copy link
Author

@backupmc backupmc commented Mar 21, 2016

Is it been already fixed via a filter update, or will it be with the next release of the app ?

@Alex-302

This comment has been minimized.

Copy link
Member

@Alex-302 Alex-302 commented Mar 21, 2016

@backupmc
it is fixed in alpha version. Filter exclusion is temporary.

@ameshkov

This comment has been minimized.

Copy link
Member

@ameshkov ameshkov commented Mar 25, 2016

@backupmc it is a program bug, so can't be fixed with filters.

Btw, beta version is already available, pretty stable:
https://github.com/AdguardTeam/AdguardForAndroid/releases

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.