Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

No internet with custom DNS in dnscrypt #528

Closed
michael1900 opened this issue Jun 12, 2019 · 16 comments
Closed

No internet with custom DNS in dnscrypt #528

michael1900 opened this issue Jun 12, 2019 · 16 comments
Assignees
Labels
Milestone

Comments

@michael1900
Copy link

@michael1900 michael1900 commented Jun 12, 2019

Hi, on osx 10.14.5, using last nightly adguard at writing moment i have this problem from at least 2-3 months:

If i set a custom dns in dnscrypt .toml file and adguard is ON i have no more internet connection!
If i leave default dns in dnscrypt .toml file and adguard is ON internet connection works well without problems.

This is with Safari, Chrome, etc.., i tried all possible combinations but the problem is Adguard.
I have many purchased license and this bug it's really tedious and it needs to be fixed because it's almost impossible to use now dnscrypt and adguard together like before.

Thanks

@ameshkov ameshkov modified the milestones: 2.0, 2.1 Jun 13, 2019
@ameshkov

This comment has been minimized.

Copy link
Member

@ameshkov ameshkov commented Jun 13, 2019

If i set a custom dns in dnscrypt .toml file and adguard is ON i have no more internet connection!

Any custom DNS server or some specific ones?

@michael1900

This comment has been minimized.

Copy link
Author

@michael1900 michael1900 commented Jun 13, 2019

I tried with many custom dns and always the same problem, try for example with dns from dnscrypt.
It's really impossible to try with all honestly, but for all those i tried the problem is there.

@ameshkov

This comment has been minimized.

Copy link
Member

@ameshkov ameshkov commented Jun 13, 2019

What DNS resolver is used by default?
How exactly have you configured dnscrypt-proxy? Is there an app or have you done it manually?

@michael1900

This comment has been minimized.

Copy link
Author

@michael1900 michael1900 commented Jun 13, 2019

These are used by default:
server_names = ['scaleway-fr', 'google', 'yandex', 'cloudflare']

You can try also with .toml from cryptostorm and all their dns:
https://github.com/cryptostorm/cstorm_deepDNS/blob/master/dnscrypt-proxy.toml

Problem is always there ;)

All manually.

@ameshkov

This comment has been minimized.

Copy link
Member

@ameshkov ameshkov commented Jun 14, 2019

We tried as well, but for some reason, we cannot reproduce the issue.

To troubleshoot this issue, we need to get the app logs.

Here's what we need you to do:

  1. Menu -> Advanced -> Logging level -> Debug
  2. Reproduce the issue (and remember the exact time when it happened).
  3. Menu -> Advanced -> Export Logs and System Info...
  4. Send the archive to apple@adguard.com and mention this issue number in the subject
@michael1900

This comment has been minimized.

Copy link
Author

@michael1900 michael1900 commented Jun 14, 2019

Done now. Hoping...

@ameshkov

This comment has been minimized.

Copy link
Member

@ameshkov ameshkov commented Jun 14, 2019

Hmm, I see nothing in the inbox. Could you please re-send it to am at adguard.com?

@michael1900

This comment has been minimized.

Copy link
Author

@michael1900 michael1900 commented Jun 14, 2019

Done.

@ameshkov

This comment has been minimized.

Copy link
Member

@ameshkov ameshkov commented Jun 14, 2019

@michael1900 thank you!

@Stillness-2 logs are in the private nextcloud

@michael1900

This comment has been minimized.

Copy link
Author

@michael1900 michael1900 commented Jun 15, 2019

Ok, i try to explain. I am on OSX, i installed dnscrypt proxy with brew. To manage all dnscrypt stuff i don't use third-party app, but all is managed manually with terminal and editing the .toml file in etc folder. Simply, no other stuff.

Now, i like to use dnscrypt server from this amazing vpn: https://github.com/cryptostorm

What to do to try and see no internet connection?
Simple: use this their custom .toml file: https://raw.githubusercontent.com/cryptostorm/cstorm_deepDNS/master/dnscrypt-proxy.toml
Install last Adguard nighlty (but for me problem starts months ago), install last dnscrypt proxy from terminal with brew, replace the default .toml file with the above cryptostorm .toml file, restart dnscrypt proxy and ... in my case there is no more internet connection working.

Now, if i close Adguard, i mean close it from Activity Manager, magically ALL internet connection now working again.

With stock dns server like google for example there is no problem.

Thanks for help

@ameshkov

This comment has been minimized.

Copy link
Member

@ameshkov ameshkov commented Jun 17, 2019

@michael1900 I figured what's wrong.

There's a bug in the current version -- it prevents UDP connections to port 443 system-wide. This will be fixed in the next update.

Meanwhile, the temporary solution would be to add the following rules to your user filter:

@@81.17.31.34:443$network
@@128.127.104.108:443$network
@@213.163.64.208:443$network
@@185.107.80.84:443$network
@@185.117.118.20:443$network
@@5.133.8.187:443$network
@@185.212.169.139:443$network
@@185.94.193.234:443$network
@@212.129.46.32:443$network
@@195.154.40.48:443$network
@@109.71.42.228:443$network
@@27.255.77.56:443$network
@@5.254.96.195:443$network
@@178.175.139.211:443$network
@@109.248.149.133:443$network
@@82.163.72.123:443$network
@@84.16.240.43:443$network
@@89.163.214.174:443$network
@@162.221.207.228:443$network
@@167.114.84.132:443$network
@@173.234.159.235:443$network
@@173.234.56.115:443$network
@@104.238.195.139:443$network
@@64.120.5.251:443$network
@@198.7.58.227:443$network
@@209.58.147.36:443$network
@@64.42.181.227:443$network
@@155.254.29.113:443$network
@@23.19.67.116:443$network
@@104.255.175.2:443$network
@michael1900

This comment has been minimized.

Copy link
Author

@michael1900 michael1900 commented Jun 19, 2019

Got it, thanks ;)

@ameshkov

This comment has been minimized.

Copy link
Member

@ameshkov ameshkov commented Jun 20, 2019

It seems my temporary solution wouldn't work:( you need to wait till the next week when we publish the fix to nightly channel.

@michael1900

This comment has been minimized.

Copy link
Author

@michael1900 michael1900 commented Jun 20, 2019

I ll wait.

@Stillness-2

This comment has been minimized.

Copy link
Member

@Stillness-2 Stillness-2 commented Jun 25, 2019

@michael1900 Check please last nightly version http://agrd.io/mac_nightly

@michael1900

This comment has been minimized.

Copy link
Author

@michael1900 michael1900 commented Jun 26, 2019

Fixed! Now i can use cryptostorm dns w/o problems, finally 👍

@TheHasagi TheHasagi closed this Jul 22, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.