Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

An issue with the userscripts updating #2500

Closed
NUser2018 opened this issue Mar 12, 2019 · 10 comments

Comments

Projects
None yet
4 participants
@NUser2018
Copy link

commented Mar 12, 2019

Обнаружил интересную проблему с обновлением пользовательских расширений\скриптов.
Проблема воспроизводится после импорта настроек программы из ранее сохраненного файла.

  1. Добавляем в AdGuard стороннее пользовательское расширение\скрипт (например RU AdList JS Fixes)
    Официальная страница https://greasyfork.org/ru/scripts/19993-ru-adlist-js-fixes
    Ссылка для установки\добавления скрипта в AdGuard https://greasyfork.org/scripts/19993-ru-adlist-js-fixes/code/RU%20AdList%20JS%20Fixes.user.js

  2. После успешной установки пользовательского скрипта в AdGuard выполняем экспорт настроек AdGuard в файл (.adg)

  3. Выполняем сброс настроек AdGuard к настройкам по умолчанию (возможно этот шаг не обязателен для воспроизведения проблемы, но все-таки лучше так на всякий случай)

  4. Выполняем импорт настроек AdGuard из ранее сохраненного файла (.adg)

  5. В итоге при попытке автоматической переустановки пользовательского расширения\скрипта (при помощи соответствующей функции в Настройки->Расширения в настройках AdGuard) получаем ошибку. Также ошибка возникает при проверке обновлений как при автоматической проверке обновлений так и при проверке обновлений вручную. В итоге пользовательский скрипт\расширение не обновляется до новой версии. (Скриншоты прилагаются)

Проблема решается путем удаления пользовательского расширения\скрипта и его повторной установки.

Но это не дело что проблема возникает при импорте настроек из конфигурационного файла. Очень надеюсь на ее исправление. По мере возможности готов оказать посильную помощь в ее исправлении.

Проблема актуальна как для релизной версии 6.4 (версия 6.4.1814.4903) так и для AdGuard 7.0 (Nightly).
ADGUserScriptError-1
ADGUserScriptError-2

@adbuker

This comment has been minimized.

Copy link

commented Mar 21, 2019

Can be related to #2447

@adbuker

This comment has been minimized.

Copy link

commented Mar 22, 2019

Indeed partially resolved in the #2447's fix, and finally resolved in adguard-windows/pull-requests/357

@NUser2018

This comment has been minimized.

Copy link
Author

commented Mar 22, 2019

Indeed partially resolved in the #2447's fix, and finally resolved in adguard-windows/pull-requests/357

The problem is solved? When and in what Adguard 7.0 Nightly build that we can test?

Проблема решена? Когда и в какой сборке Adguard 7.0 Nightly это можно будет проверить?

@adbuker

This comment has been minimized.

Copy link

commented Mar 22, 2019

The problem has been succefully solved and will be included in one of the nearest nightlies - today evening or the beginning of the next week.

@NUser2018

This comment has been minimized.

Copy link
Author

commented Mar 22, 2019

The problem has been succefully solved and will be included in one of the nearest nightlies - today evening or the beginning of the next week.

OK, will check, then write here the result. Please do not close this task yet. Although it would still be nice to know about the output of a particular Assembly with a specific number with this fix. If you can, please write here please when a specific build with this fix will be released.

OK, проверю, напишу потом здесь результат. Не закрывайте пожалуйста пока эту задачу. Хотя было бы все же неплохо узнать о выходе конкретной сборки с конкретным номером с данным исправлением. Если сможете, пожалуйста напишите здесь пожалуйста тогда когда уже выйдет конкретная сборка с данным исправлением.

@adbuker adbuker changed the title Проблема с обновлением пользовательских расширений\скриптов An issue with the userscripts updating Mar 22, 2019

@adbuker

This comment has been minimized.

Copy link

commented Mar 22, 2019

Обязательно укажу здесть номер сборки!

@NUser2018

This comment has been minimized.

Copy link
Author

commented Mar 22, 2019

Обязательно укажу здесть номер сборки!

Хорошо. Спасибо. Буду ждать.
Good. Thanks. I'll wait.

@adbuker

This comment has been minimized.

Copy link

commented Mar 22, 2019

@NUser2018 , попробуйте новую найтли 7.0.2373, там исправления уже есть

@NUser2018

This comment has been minimized.

Copy link
Author

commented Mar 23, 2019

@NUser2018 , попробуйте новую найтли 7.0.2373, там исправления уже есть

Для обновления доступна сборка 7.0.2372.6019. Исправление проблемы указано у нее в списке изменений. Проверил. Проблема исправлена. Спасибо.
Build 7.0.2372.6019 is available for upgrade. Fix problems mentioned in her list of changes. Verified. The issue is fixed. Thanks.

@adbuker

This comment has been minimized.

Copy link

commented Mar 25, 2019

да, именно эта найтли, перепутал номер)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.