New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Chrome browser randomly hangs (ESET compatibility issue) #899

Closed
ameshkov opened this Issue Feb 20, 2016 · 14 comments

Comments

Projects
None yet
5 participants

@ameshkov ameshkov self-assigned this Feb 20, 2016

@ameshkov ameshkov added this to the 6.0 R2 milestone Feb 20, 2016

@lloy0076

This comment has been minimized.

Show comment
Hide comment
@lloy0076

lloy0076 Feb 28, 2016

This is happening to me with AdGuard 6.0.189.984 and I'd put the latest version of Chrome; I am running Sophos Antivirus 10.3 and Windows Version 1511 (OS Build 10586.104), i.e. Windows Home, not enabled for development/beta.

lloy0076 commented Feb 28, 2016

This is happening to me with AdGuard 6.0.189.984 and I'd put the latest version of Chrome; I am running Sophos Antivirus 10.3 and Windows Version 1511 (OS Build 10586.104), i.e. Windows Home, not enabled for development/beta.

@ameshkov

This comment has been minimized.

Show comment
Hide comment
@ameshkov

ameshkov Mar 1, 2016

Member

It seems that we currently have a compatibility issue with all Sophos AVs:
#866

Member

ameshkov commented Mar 1, 2016

It seems that we currently have a compatibility issue with all Sophos AVs:
#866

@ameshkov

This comment has been minimized.

Show comment
Hide comment

@ameshkov ameshkov changed the title from Chrome browser randomly hangs to Chrome browser randomly hangs (ESET compatibility issue) Mar 4, 2016

@lloy0076

This comment has been minimized.

Show comment
Hide comment
@lloy0076

lloy0076 Mar 10, 2016

This still happens wit the above setup.exe.

Verified by:

  1. Install the above setup.exe (6.0.204.1025) and it claims it's a 6.0 beta;
  2. Leave Sophos services etc running;
  3. Run chrome;
  4. Chrome cannot seem to connect to Internet and when attempting to force the chrome process and its entire tree to stop in task manager I get "Access is Denied".

Thus, Chrome won't start again.

Then I:

  1. Stopped all my Sophos services;
  2. Rebooted;
  3. Chrome works again.

lloy0076 commented Mar 10, 2016

This still happens wit the above setup.exe.

Verified by:

  1. Install the above setup.exe (6.0.204.1025) and it claims it's a 6.0 beta;
  2. Leave Sophos services etc running;
  3. Run chrome;
  4. Chrome cannot seem to connect to Internet and when attempting to force the chrome process and its entire tree to stop in task manager I get "Access is Denied".

Thus, Chrome won't start again.

Then I:

  1. Stopped all my Sophos services;
  2. Rebooted;
  3. Chrome works again.
@Eugene-Savenko

This comment has been minimized.

Show comment
Hide comment
@Eugene-Savenko

Eugene-Savenko Mar 17, 2016

Member

DQS-496-95490

Finally managed to find some time to reproduce the issue.
I have never used the WFP driver since as I understood it is only meant for windows store apps based browsers.
I use 3 browsers at the same time: Firefox (64bit), Opera (32bit) and Chrome (64bit). And out of these only chrome will hang after usage.
I have also tried disabling ESET 9 antivirus (without firewall) engine, but it still hangs.
Should I completely uninstall ESET to be sure?

Hello!

I recently installed the desktop version to my work PC, and quickly noticed that 2 certain applications began hanging in OS driver level.
Namely the latest stable version of Google Chrome (64bit) and Java 7 (64bit) hang after certain time of usage in such a way they cannot be terminated from task manager (access denied) which is why I suspect the driver of Adguard being at fault. The issue reproduced after restarting the machine, and has not reproduced after removing Adguard.
PC: Windows 10 64bit (upgrade from win7, so the drivers of the machine could be faulty, but since it is a work machine I cannot resort to clean install of windows.) Other network drivers installed: ESET antivirus and Oracle VM VirtualBox
Is there something I can do to better debug the problem?

Member

Eugene-Savenko commented Mar 17, 2016

DQS-496-95490

Finally managed to find some time to reproduce the issue.
I have never used the WFP driver since as I understood it is only meant for windows store apps based browsers.
I use 3 browsers at the same time: Firefox (64bit), Opera (32bit) and Chrome (64bit). And out of these only chrome will hang after usage.
I have also tried disabling ESET 9 antivirus (without firewall) engine, but it still hangs.
Should I completely uninstall ESET to be sure?

Hello!

I recently installed the desktop version to my work PC, and quickly noticed that 2 certain applications began hanging in OS driver level.
Namely the latest stable version of Google Chrome (64bit) and Java 7 (64bit) hang after certain time of usage in such a way they cannot be terminated from task manager (access denied) which is why I suspect the driver of Adguard being at fault. The issue reproduced after restarting the machine, and has not reproduced after removing Adguard.
PC: Windows 10 64bit (upgrade from win7, so the drivers of the machine could be faulty, but since it is a work machine I cannot resort to clean install of windows.) Other network drivers installed: ESET antivirus and Oracle VM VirtualBox
Is there something I can do to better debug the problem?

@ameshkov

This comment has been minimized.

Show comment
Hide comment
@ameshkov

ameshkov Mar 18, 2016

Member

I'll do some more experiments on monday.

I use 3 browsers at the same time: Firefox (64bit), Opera (32bit) and Chrome (64bit). And out of these only chrome will hang after usage.

This could be very important, really. I've asked user to test Chrome with QUIC disabled (as this is the only serious difference between Opera and Chrome)

Member

ameshkov commented Mar 18, 2016

I'll do some more experiments on monday.

I use 3 browsers at the same time: Firefox (64bit), Opera (32bit) and Chrome (64bit). And out of these only chrome will hang after usage.

This could be very important, really. I've asked user to test Chrome with QUIC disabled (as this is the only serious difference between Opera and Chrome)

@ameshkov

This comment has been minimized.

Show comment
Hide comment
@ameshkov

ameshkov Mar 18, 2016

Member

@lloy0076 I suppose that in your case switching to TDI driver should fix the issue (at least temporary until we find a way to fix WFP driver).

To do this:

  1. Go to AG settings
  2. Uncheck "Use WFP driver" box there.
Member

ameshkov commented Mar 18, 2016

@lloy0076 I suppose that in your case switching to TDI driver should fix the issue (at least temporary until we find a way to fix WFP driver).

To do this:

  1. Go to AG settings
  2. Uncheck "Use WFP driver" box there.
@lloy0076

This comment has been minimized.

Show comment
Hide comment
@lloy0076

lloy0076 Mar 19, 2016

@ameshkov - this worked in a sense that Chrome seems to be able to start and restart but AdGuard claims that the new interface for Microsoft Edge cannot be filtered with the TDI driver which somewhat defeats the reason why I'm using AdGuard in the first place...

So, it seems I can:

  1. Use the WFP drivers and Windows Defender but Chrome only once; or
  2. Use the TDI drivers and use Chrome as much as I like but MS Edge has no ad blocker.

Thanks for the tip, though.

lloy0076 commented Mar 19, 2016

@ameshkov - this worked in a sense that Chrome seems to be able to start and restart but AdGuard claims that the new interface for Microsoft Edge cannot be filtered with the TDI driver which somewhat defeats the reason why I'm using AdGuard in the first place...

So, it seems I can:

  1. Use the WFP drivers and Windows Defender but Chrome only once; or
  2. Use the TDI drivers and use Chrome as much as I like but MS Edge has no ad blocker.

Thanks for the tip, though.

@vozersky

This comment has been minimized.

Show comment
Hide comment
@vozersky

vozersky Mar 23, 2016

Member

update from DQS-496-95490

"I can now confirm that after overnight usage the Opera did finally hang too. So my previous assumption was incorrect, but it did take a lot longer for Opera to reach its hang state."

"I disabled the #enable-quic in Chrome but it still hangs.
Also I had no trouble using 2 Opera browsers (stable and beta) for a full day without issues.
It could be because both Opera's are 32 bit and Chrome is 64bit, so 32bit chrome should be verified too.
The issue is also not reproducing in my home PC where I also have 64bit chrome but an older version of ESET (v8)."

Member

vozersky commented Mar 23, 2016

update from DQS-496-95490

"I can now confirm that after overnight usage the Opera did finally hang too. So my previous assumption was incorrect, but it did take a lot longer for Opera to reach its hang state."

"I disabled the #enable-quic in Chrome but it still hangs.
Also I had no trouble using 2 Opera browsers (stable and beta) for a full day without issues.
It could be because both Opera's are 32 bit and Chrome is 64bit, so 32bit chrome should be verified too.
The issue is also not reproducing in my home PC where I also have 64bit chrome but an older version of ESET (v8)."

@ameshkov

This comment has been minimized.

Show comment
Hide comment
@ameshkov

ameshkov Mar 25, 2016

Member

@lloy0076 yeah, that's the problem with TDI. I hope the issue will be resolved with a new WFP driver we're working on, but it will take some time to finish with it.

Member

ameshkov commented Mar 25, 2016

@lloy0076 yeah, that's the problem with TDI. I hope the issue will be resolved with a new WFP driver we're working on, but it will take some time to finish with it.

@lloy0076

This comment has been minimized.

Show comment
Hide comment
@lloy0076

lloy0076 Mar 25, 2016

@ameshkov - thanks for the timely and relevant updates :)

lloy0076 commented Mar 25, 2016

@ameshkov - thanks for the timely and relevant updates :)

@ameshkov

This comment has been minimized.

Show comment
Hide comment
@ameshkov

ameshkov Mar 29, 2016

Member

New build, it can fix the issue with ESET:
https://cdn.adguard.com/public/Adguard/github/AdguardForWindows/issue899/setup_6.0.214.1066.exe

@lloy0076 Sophos issue not yet fixed. Please subscribe to #866, I'll update it as soon as new driver is ready.

Member

ameshkov commented Mar 29, 2016

New build, it can fix the issue with ESET:
https://cdn.adguard.com/public/Adguard/github/AdguardForWindows/issue899/setup_6.0.214.1066.exe

@lloy0076 Sophos issue not yet fixed. Please subscribe to #866, I'll update it as soon as new driver is ready.

@xtwmx

This comment has been minimized.

Show comment
Hide comment
@xtwmx

xtwmx Mar 31, 2016

New build, it can fix the issue with ESET:
https://cdn.adguard.com/public/Adguard/github/AdguardForWindows/issue899/setup_6.0.214.1066.exe

So far so good, has not reproduced after a full day of work with Chrome and Opera.

xtwmx commented Mar 31, 2016

New build, it can fix the issue with ESET:
https://cdn.adguard.com/public/Adguard/github/AdguardForWindows/issue899/setup_6.0.214.1066.exe

So far so good, has not reproduced after a full day of work with Chrome and Opera.

@ameshkov

This comment has been minimized.

Show comment
Hide comment
@ameshkov

ameshkov Mar 31, 2016

Member

Huge relief, thank you!

Member

ameshkov commented Mar 31, 2016

Huge relief, thank you!

@ameshkov ameshkov closed this Apr 4, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment