Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We鈥檒l occasionally send you account related emails.

Already on GitHub? Sign in to your account

ACF PRO test version 5.7.11 #125

Open
elliotcondon opened this issue Feb 4, 2019 · 17 comments

Comments

Projects
None yet
8 participants
@elliotcondon
Copy link
Contributor

commented Feb 4, 2019

Hi all 馃憢,

The next version of ACF PRO is nearly complete and contains a lot of refactored code that needs to be tested. This version starts a long process of tidying up the entire ACF codebase which I will continue throughout the year.

Specifically, this version contains refactored code for the low level functions used throughout the plugin:

  • Field functions
  • Field group functions
  • Meta functions
  • Value functions

In the process of refactoring, I have addressed many of the cache issues that have plagued ACF. As a result, ACF now correctly caches results to minimize database calls. I suggest using the Query Monitor plugin to view database calls in order to test this.

I will be very grateful if you can spend some time testing out the "5.7.11-beta1" version available from your account online. Just click the "See all versions" link alongside your license for all the available version downloads.

Areas to focus are:

  • Editing a field group
  • Editing a post, user, comment, widget, term, options page
  • Using the "Local JSON" feature
  • Syncing, exporting and importing field groups
  • Testing Memcached and reviewing SQL queries

Thanks in advance for any and all help you are able to provide. I'm extremely proud of the work that has gone into this version and I can't wait to release this update.

Please post any issues found here on GitHub 馃憤.

馃帀馃帀馃帀

Thanks
Elliot

@elliotcondon

This comment has been minimized.

Copy link
Contributor Author

commented Feb 4, 2019

For those wondering about "ACF PRO 5.8.0-beta3", I will return my full attention back to the 5.8 branch after this 5.7.11 version is released.

@johanhermansson

This comment has been minimized.

Copy link

commented Feb 4, 2019

Looking forward to testing this 馃憤 I hope it will fix the field sorting problems I've had with fields within Flexible content when synchronising them from the local JSON files.

@matthiaswagnerwy

This comment has been minimized.

Copy link

commented Feb 11, 2019

hy,
i just installed 5.7.11 and found out that slashes are added to single and double quotes in my textarea-field in an options page when saving the new input. i tried to figure out if other plugins could be the reason, but it looks like this comes from acf.
any hints on this?

matt

@jossoway

This comment has been minimized.

Copy link

commented Feb 11, 2019

@matthiaswagnerwy @elliotcondon I am encountering the same issue since upgrading a site staging environment to 5.7.11. I rolled back to 5.7.10 and the issue disappeared.

@sethwhitaker

This comment has been minimized.

Copy link

commented Feb 11, 2019

Did this get pushed to Wordpress plugin database early by accident? This update broke all my flexible content tab areas. We have a pretty complex page builder with ACF and flex content fields which has gotten all sorts of messed up with 5.7.11

@elliotcondon

This comment has been minimized.

Copy link
Contributor Author

commented Feb 12, 2019

@matthiaswagnerwy Thanks. I've just replicated and fixed this bug.

@elliotcondon

This comment has been minimized.

Copy link
Contributor Author

commented Feb 12, 2019

@sethwhitaker Yes. ACF PRO 5.7.11 has been released. If you are experiencing an issue with the flexible content field, please help me replicate the issue and I'll be sure to get it fixed ASAP.

@sethwhitaker

This comment has been minimized.

Copy link

commented Feb 13, 2019

Going to be hard to get you to replicate the issue because we have a whole system in place for dynamically generating flex content layout fields in a page builder from php arrays. I would need to give you access to our system to help you track it down.

The interesting thing though, is that I downloaded the 5.8 beta 3 and it was back to normal. So there is definitely something weird going on in 5.7.11 with tabs. Because its the part of our class that deals with dynamically setting up some tab sections by injecting some fields into the default fields array which is acting wonky. The First tab that im injecting is not getting added, but like i said, its totally fine in 5.7.10 and 5.8b3.

Just looking at a changelog from 5.7.10 to 5.7.11 it just looked like you made a lot of changes for such a minor version bump.

@elliotcondon

This comment has been minimized.

Copy link
Contributor Author

commented Feb 13, 2019

Hi @sethwhitaker

We refactored a lot of code in 5.7.11 but did not intend to make any breaking changes. I'm motivated to find and fix these issues, so if you are able to, please create a simple environment to replicate the issue. Perhaps there is a bug with one of the filters you are using? OR perhaps a bug in the "Local Fields" logic.

@sethwhitaker

This comment has been minimized.

Copy link

commented Feb 14, 2019

I know its not helpful for you, but im not going to be able to set up a test environment because its company code. Doing more digging, I do think the issue lies somewhere in the add_local_field_group logic. We have a custom wrapper class around that function where we inject our custom tab fields and thats the location ive pinpointed where its breaking in 5.7.11.

Have the changes you made in 5.7.11 also made it into 5.8b? could the reason that 5.8 is working fine because its based off of 5.7.10?

@elliotcondon

This comment has been minimized.

Copy link
Contributor Author

commented Feb 14, 2019

@sethwhitaker ACF PRO 5.8.0-beta3 does not contain any of the updates from 5.7.11.
I intend to release a 5.8.0-beta4 shortly to include all the new 5.7.x changes from the past few months.

@wcjonathan

This comment has been minimized.

Copy link

commented Feb 15, 2019

I have an issue when updating to version 5.7.11+ where ACF Gallery fields stop working and outputting any previously added images (not all images though strangely enough). Reverting back to version 5.7.10 brings back the images. I have tried 5.7.12 this morning but it's still broken.

@sethwhitaker

This comment has been minimized.

Copy link

commented Feb 15, 2019

The changelog on 5.7.12 looked promising for the fixes you made, but it still it broken for us. Ill do my best this weekend to try to set up a simplified test environment for you to look at.

@elliotcondon

This comment has been minimized.

Copy link
Contributor Author

commented Feb 15, 2019

@wcjonathan Thanks for the feedback. Can you please open a support ticket with a detailed description to replicate the issue? https://www.advancedcustomfields.com/contact/

@chuckreynolds

This comment has been minimized.

Copy link

commented Feb 20, 2019

upgraded from 5.7.10 -> 5.7.12 and so far it looks like that fixed the issues I was having with json config not being saved and certain parts on the front-end not being rendered using object cache. (using simple-cache plugin)
...so far. lookin good.

@alicam

This comment has been minimized.

Copy link

commented May 7, 2019

@elliotcondon Did this all make its way into PRO v5.8 ?? I can't immediately tell if it did...

A

@elliotcondon

This comment has been minimized.

Copy link
Contributor Author

commented May 7, 2019

Hi @alicam

Yes. These improvements were included in the 5.7.11 update :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can鈥檛 perform that action at this time.