'cannot load such file -- zip/zip' #76

Closed
vorou opened this Issue Sep 7, 2013 · 2 comments

Comments

Projects
None yet
2 participants
@vorou

vorou commented Sep 7, 2013

Here's my Rakefile:

require 'albacore'

task :default => [:build]

desc 'Build ImportService'
task :build do |msb|
end

Here's the output of rake --trace command:

rake aborted!
cannot load such file -- zip/zip
C:/Ruby200-x64/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
C:/Ruby200-x64/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/albacore-0.3.5/lib/albacore/unzip.rb:2:in `<top (required)>'
C:/Ruby200-x64/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
C:/Ruby200-x64/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/albacore-0.3.5/lib/albacore.rb:9:in `block in <top (required)>'
C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/albacore-0.3.5/lib/albacore.rb:9:in `each'
C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/albacore-0.3.5/lib/albacore.rb:9:in `<top (required)>'
C:/Ruby200-x64/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:110:in `require'
C:/Ruby200-x64/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:110:in `rescue in require'
C:/Ruby200-x64/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:35:in `require'
F:/Gofra/Source/Rakefile:1:in `<top (required)>'
C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rake-10.1.0/lib/rake/rake_module.rb:25:in `load'
C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rake-10.1.0/lib/rake/rake_module.rb:25:in `load_rakefile'
C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rake-10.1.0/lib/rake/application.rb:637:in `raw_load_rakefile'
C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rake-10.1.0/lib/rake/application.rb:94:in `block in load_rakefile'
C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rake-10.1.0/lib/rake/application.rb:165:in `standard_exception_handling'
C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rake-10.1.0/lib/rake/application.rb:93:in `load_rakefile'
C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rake-10.1.0/lib/rake/application.rb:77:in `block in run'
C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rake-10.1.0/lib/rake/application.rb:165:in `standard_exception_handling'
C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rake-10.1.0/lib/rake/application.rb:75:in `run'
C:/Ruby200-x64/lib/ruby/gems/2.0.0/gems/rake-10.1.0/bin/rake:33:in `<top (required)>'
C:/Ruby200-x64/bin/rake:23:in `load'
C:/Ruby200-x64/bin/rake:23:in `<main>'

I have both albacore & rubyzip gems installed, here's gem list:

*** LOCAL GEMS ***

albacore (0.3.5)
amq-protocol (1.7.0)
bigdecimal (1.2.1, 1.2.0)
bunny (0.10.6, 0.10.2)
io-console (0.4.2)
json (1.8.0, 1.7.7)
minitest (5.0.7, 4.3.2)
psych (2.0.0)
rake (10.1.0, 0.9.6)
rdoc (4.0.1, 4.0.0)
rubyzip (1.0.0)
test-unit (2.5.5, 2.0.0.0)

I'm using W7 x64, ruby 2.0.0p247 (2013-06-27) [x64-mingw32]

@AnthonyMastrean

This comment has been minimized.

Show comment
Hide comment
@AnthonyMastrean

AnthonyMastrean Sep 9, 2013

Member

Bad dependency specification, pushing a change very soon... related to #76

Member

AnthonyMastrean commented Sep 9, 2013

Bad dependency specification, pushing a change very soon... related to #76

@AnthonyMastrean

This comment has been minimized.

Show comment
Hide comment
@AnthonyMastrean

AnthonyMastrean Sep 9, 2013

Member

Fixed in the latest prerelease gem, please gem install albacore --pre

Member

AnthonyMastrean commented Sep 9, 2013

Fixed in the latest prerelease gem, please gem install albacore --pre

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment