Rubyzip 1.0 #77

Merged
merged 2 commits into from Oct 21, 2013

Conversation

Projects
None yet
2 participants
@b-dean
Contributor

b-dean commented Oct 21, 2013

Our build scripts that use albacore use other gems as well and some of them depend on rubyzip 1.0.0. This change is to make it so albacore will work with rubyzip 1.0.0

I know you're getting ready to release albacore 1.0.0, I think this would be a great change to get into that release since you're already going up a major version and then you'd be on the latest version of rubyzip as opposed to be tied to an older verison.

Also, the zip_spec tests weren't passing even before my change to rubyzip 1.0. So my first changeset is to make those tests pass, so I would know that my change to rubyzip 1.0 works.

b-dean added some commits Oct 18, 2013

fixing zip_spec
The spec was written in such a way that most of the examples were expecting the zip to be flattened but the default is to not flatten.
change gemspec to depend on rubyzip ~> 1.0
fixing unzip and zipdirectory to use the new rubyzip

AnthonyMastrean added a commit that referenced this pull request Oct 21, 2013

@AnthonyMastrean AnthonyMastrean merged commit 5e1c778 into Albacore:master Oct 21, 2013

@AnthonyMastrean

This comment has been minimized.

Show comment
Hide comment
@AnthonyMastrean

AnthonyMastrean Oct 21, 2013

Member

Thanks for the hard work. I'm going to merge and test and maybe we'll have another prerelease gem tonight. Thanks!

Member

AnthonyMastrean commented Oct 21, 2013

Thanks for the hard work. I'm going to merge and test and maybe we'll have another prerelease gem tonight. Thanks!

@b-dean b-dean deleted the b-dean:rubyzip-1.0 branch Oct 22, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment