Permalink
Browse files

Fixes rails version dependence and removes fuubar rspec format

  • Loading branch information...
1 parent f2a23aa commit b7e732bc2a7dadf2c35ac3eb2dae547989aac55a Thomas von Deyen committed Apr 24, 2012
Showing with 4 additions and 5 deletions.
  1. +0 −1 .rspec
  2. +2 −2 lib/alchemy_cms.rb
  3. +2 −2 spec/spec_helper.rb
View
@@ -1,2 +1 @@
---format Fuubar
--color
View
@@ -1,4 +1,4 @@
-if defined?(Rails) && Rails::VERSION::MAJOR == 3
+if defined?(Rails) && Rails::VERSION::MAJOR == 3 && Rails::VERSION::MINOR == 2
require 'acts_as_list'
require 'attachment_magic'
require 'authlogic'
@@ -23,7 +23,7 @@
end
require File.join(File.dirname(__FILE__), "alchemy", "seeder")
else
- raise "Alchemy 2.1 needs Rails 3.1 or higher. You are currently using Rails #{Rails::VERSION::STRING}"
+ raise "Alchemy 2.2 needs Rails 3.2 or higher. You are currently using Rails #{Rails::VERSION::STRING}"
end
module Alchemy
View
@@ -28,10 +28,10 @@ def configure
# Configure capybara for integration testing
require "capybara/rails"
- require 'capybara-webkit'
+ require 'capybara-webkit' unless ENV['CI']
Capybara.default_driver = :rack_test
Capybara.default_selector = :css
- Capybara.javascript_driver = :webkit
+ Capybara.javascript_driver = :webkit unless ENV['CI']
# Load support files
Dir["#{File.dirname(__FILE__)}/support/**/*.rb"].each { |f| require f }

0 comments on commit b7e732b

Please sign in to comment.