Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

go alive

  • Loading branch information...
commit 77b25ea60252288fa50e51ba922bd48f1f169a0f 1 parent d689015
@AlexVangelov authored
View
1  .gitignore
@@ -0,0 +1 @@
+sencha-touch-rails-1.0.0.gem
View
5 .project
@@ -5,6 +5,11 @@
<projects>
</projects>
<buildSpec>
+ <buildCommand>
+ <name>com.aptana.ide.core.unifiedBuilder</name>
+ <arguments>
+ </arguments>
+ </buildCommand>
</buildSpec>
<natures>
<nature>com.aptana.ruby.core.rubynature</nature>
View
13 README.md
@@ -0,0 +1,13 @@
+# sencha-touch-rails
+
+This gem provides:
+
+* Sencha Touch 2.0.0.beta3
+
+## Rails 3.1
+
+For Rails 3.1 and greater, the files will be added to the asset pipeline and available for you to use. These two lines will be added to the file `app/assets/javascripts/application.js` by default:
+
+ //= require sencha-touch-all
+ or
+ //= require sencha-touch-all-debug
View
1  lib/sencha-touch-rails.rb
@@ -0,0 +1 @@
+require 'sencha-touch/rails'
View
6 lib/sencha-touch/rails.rb
@@ -0,0 +1,6 @@
+module SenchaTouch
+ module Rails
+ require 'sencha-touch/rails/engine'
+ require 'sencha-touch/rails/version'
+ end
+end
View
7 lib/sencha-touch/rails/engine.rb
@@ -0,0 +1,7 @@
+# Configure Rails 3.1 to have assert_select_jquery() in tests
+module SenchaTouch
+ module Rails
+ class Engine < ::Rails::Engine
+ end
+ end
+end
View
9 sencha-touch-rails.gemspec
@@ -7,18 +7,15 @@ Gem::Specification.new do |s|
s.platform = Gem::Platform::RUBY
s.authors = ["Alex Vangelov"]
s.email = ["email@data.bg"]
- s.homepage = "http://rubygems.org/gems/sencha-touch-rails"
+ s.homepage = "http://rubygems.org/gems/sencha-touc-rails"
s.summary = "Use Sencha Touch with Rails 3"
- s.description = "This gem provides Sencha Touch driver for your Rails 3 application."
+ s.description = "This gem provides Sencha Touch driver for Rails 3 applications"
s.required_rubygems_version = ">= 1.3.6"
s.rubyforge_project = "sencha-touch-rails"
- s.add_dependency "railties", "~> 3.2"
+ s.add_dependency "railties", ">= 3.2.0.beta", "< 5.0"
s.add_dependency "thor", "~> 0.14"
- s.add_development_dependency "bundler", "~> 1.0.0"
- s.add_development_dependency "rails", "~> 3.0"
- s.add_dependency "compass", "~>0.11.7"
s.files = `git ls-files`.split("\n")
s.executables = `git ls-files`.split("\n").select{|f| f =~ /^bin/}

0 comments on commit 77b25ea

Please sign in to comment.
Something went wrong with that request. Please try again.