Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

empty gem

  • Loading branch information...
commit cef4c25020bf4cc824bf8c8e9817fba0eff4f597 1 parent 69ee72b
@AlexVangelov authored
View
12 .project
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<projectDescription>
+ <name>sencha-touch-rails</name>
+ <comment></comment>
+ <projects>
+ </projects>
+ <buildSpec>
+ </buildSpec>
+ <natures>
+ <nature>com.aptana.ruby.core.rubynature</nature>
+ </natures>
+</projectDescription>
View
3  CHANGELOG.md
@@ -0,0 +1,3 @@
+## 1.0.0 (16 Feb 2012)
+ Starting..
+ Minimal requirements is to include sencha touch js
View
9 Gemfile
@@ -0,0 +1,9 @@
+source :gemcutter
+
+# Specify your gem's dependencies in jquery-rails.gemspec
+gemspec
+# Rails is already being pulled in through gemspec
+# gem "rails", :git => "git://github.com/rails/rails.git"
+gem "rack"
+gem "sprockets"
+gem "i18n"
View
105 Gemfile.lock
@@ -0,0 +1,105 @@
+PATH
+ remote: .
+ specs:
+ sencha-touch-rails (1.0.0)
+ compass (~> 0.11.7)
+ railties (~> 3.2)
+ thor (~> 0.14)
+
+GEM
+ remote: http://rubygems.org/
+ specs:
+ actionmailer (3.2.1)
+ actionpack (= 3.2.1)
+ mail (~> 2.4.0)
+ actionpack (3.2.1)
+ activemodel (= 3.2.1)
+ activesupport (= 3.2.1)
+ builder (~> 3.0.0)
+ erubis (~> 2.7.0)
+ journey (~> 1.0.1)
+ rack (~> 1.4.0)
+ rack-cache (~> 1.1)
+ rack-test (~> 0.6.1)
+ sprockets (~> 2.1.2)
+ activemodel (3.2.1)
+ activesupport (= 3.2.1)
+ builder (~> 3.0.0)
+ activerecord (3.2.1)
+ activemodel (= 3.2.1)
+ activesupport (= 3.2.1)
+ arel (~> 3.0.0)
+ tzinfo (~> 0.3.29)
+ activeresource (3.2.1)
+ activemodel (= 3.2.1)
+ activesupport (= 3.2.1)
+ activesupport (3.2.1)
+ i18n (~> 0.6)
+ multi_json (~> 1.0)
+ arel (3.0.0)
+ builder (3.0.0)
+ chunky_png (1.2.5)
+ compass (0.11.7)
+ chunky_png (~> 1.2)
+ fssm (>= 0.2.7)
+ sass (~> 3.1)
+ erubis (2.7.0)
+ fssm (0.2.8.1)
+ hike (1.2.1)
+ i18n (0.6.0)
+ journey (1.0.1)
+ json (1.6.5)
+ mail (2.4.1)
+ i18n (>= 0.4.0)
+ mime-types (~> 1.16)
+ treetop (~> 1.4.8)
+ mime-types (1.17.2)
+ multi_json (1.0.4)
+ polyglot (0.3.3)
+ rack (1.4.1)
+ rack-cache (1.1)
+ rack (>= 0.4)
+ rack-ssl (1.3.2)
+ rack
+ rack-test (0.6.1)
+ rack (>= 1.0)
+ rails (3.2.1)
+ actionmailer (= 3.2.1)
+ actionpack (= 3.2.1)
+ activerecord (= 3.2.1)
+ activeresource (= 3.2.1)
+ activesupport (= 3.2.1)
+ bundler (~> 1.0)
+ railties (= 3.2.1)
+ railties (3.2.1)
+ actionpack (= 3.2.1)
+ activesupport (= 3.2.1)
+ rack-ssl (~> 1.3.2)
+ rake (>= 0.8.7)
+ rdoc (~> 3.4)
+ thor (~> 0.14.6)
+ rake (0.9.2.2)
+ rdoc (3.12)
+ json (~> 1.4)
+ sass (3.1.15)
+ sprockets (2.1.2)
+ hike (~> 1.2)
+ rack (~> 1.0)
+ tilt (~> 1.1, != 1.3.0)
+ thor (0.14.6)
+ tilt (1.3.3)
+ treetop (1.4.10)
+ polyglot
+ polyglot (>= 0.3.1)
+ tzinfo (0.3.31)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ bundler (~> 1.0.0)
+ i18n
+ rack
+ rails (~> 3.0)
+ sencha-touch-rails!
+ sprockets
View
10 Rakefile
@@ -0,0 +1,10 @@
+require 'bundler'
+Bundler::GemHelper.install_tasks
+
+# require "spec/rake/spectask"
+# desc "Run all examples"
+# Spec::Rake::SpecTask.new(:spec) do |t|
+# t.ruby_opts = ['-r test/unit']
+# t.spec_opts = %w[--color]
+# end
+task :default => :spec
View
6 lib/sencha-touch/rails/version.rb
@@ -0,0 +1,6 @@
+module SenchaTouch
+ module Rails
+ VERSION = "1.0.0"
+ SENCHA_TOUCH_VERSION = "2.0.0.beta3"
+ end
+end
View
26 sencha-touch-rails.gemspec
@@ -0,0 +1,26 @@
+# -*- encoding: utf-8 -*-
+require File.expand_path('../lib/sencha-touch/rails/version', __FILE__)
+
+Gem::Specification.new do |s|
+ s.name = "sencha-touch-rails"
+ s.version = SenchaTouch::Rails::VERSION
+ s.platform = Gem::Platform::RUBY
+ s.authors = ["Alex Vangelov"]
+ s.email = ["email@data.bg"]
+ s.homepage = "http://rubygems.org/gems/sencha-touch-rails"
+ s.summary = "Use Sencha Touch with Rails 3"
+ s.description = "This gem provides Sencha Touch driver for your Rails 3 application."
+
+ s.required_rubygems_version = ">= 1.3.6"
+ s.rubyforge_project = "sencha-touch-rails"
+
+ s.add_dependency "railties", "~> 3.2"
+ s.add_dependency "thor", "~> 0.14"
+ s.add_development_dependency "bundler", "~> 1.0.0"
+ s.add_development_dependency "rails", "~> 3.0"
+ s.add_dependency "compass", "~>0.11.7"
+
+ s.files = `git ls-files`.split("\n")
+ s.executables = `git ls-files`.split("\n").select{|f| f =~ /^bin/}
+ s.require_path = 'lib'
+end
Please sign in to comment.
Something went wrong with that request. Please try again.