Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Access violation error in Ubuntu 16.04 #1645

Closed
shamilchoudhury opened this issue Oct 18, 2018 · 23 comments
Closed

Access violation error in Ubuntu 16.04 #1645

shamilchoudhury opened this issue Oct 18, 2018 · 23 comments

Comments

@shamilchoudhury
Copy link

@shamilchoudhury shamilchoudhury commented Oct 18, 2018

Installed CudaText from .deb . When I try opening any file, I get this error:

screenshot_2018-10-19_00-41-40

If I click ok, CudaText starts for a second and closes.

@Alexey-T

This comment has been minimized.

Copy link
Owner

@Alexey-T Alexey-T commented Oct 18, 2018

Pls run "cudatext" from terminal, what error text is shows?

@Alexey-T

This comment has been minimized.

Copy link
Owner

@Alexey-T Alexey-T commented Oct 18, 2018

  1. How do you run Cudatext? via Applications menu of Ubuntu?
@Alexey-T

This comment has been minimized.

Copy link
Owner

@Alexey-T Alexey-T commented Oct 18, 2018

  1. Try to write to settings/user.json (in other editor)

    "pylib__linux": "ddd",

@shamilchoudhury

This comment has been minimized.

Copy link
Author

@shamilchoudhury shamilchoudhury commented Oct 19, 2018

Pls run "cudatext" from terminal, what error text is shows?

ERROR in code: TGtk2WidgetSet.CreateBitmapFromRawImage Incompatible DataSize
Creating gdb catchable error:

  $00000000005A5029
  $00000000005A04C5
  $00000000006CA24D
  $0000000000544566
  $00000000005FB4B9
  $00000000006059F5
  $000000000060B4F5
  $000000000060EE1E
  $000000000061934B
TRasterImage.BitmapHandleNeeded: Unable to create handles, using default
ERROR in code: TGtk2WidgetSet.CreateBitmapFromRawImage Incompatible DataSize
Creating gdb catchable error:

  $00000000005A5029
  $00000000005A04C5
  $00000000006CA24D
  $0000000000544566
  $00000000005FB4B9
  $00000000006059F5
  $000000000060B4F5
  $000000000060EE1E
  $000000000061934B
TRasterImage.BitmapHandleNeeded: Unable to create handles, using default
TControl.ChangeBounds test(1):TATScroll Old=23006,0,14,466 New=56402,0,14,947 Real=56402,0,14,947
TControl.ChangeBounds test(2):TATScroll Old=23006,0,14,466 New=56402,0,14,947 Real=56402,0,14,947
TControl.ChangeBounds test(3):TATScroll Old=23006,0,14,466 New=56402,0,14,947 Real=56402,0,14,947
TControl.ChangeBounds test(4):TATScroll Old=23006,0,14,466 New=56402,0,14,947 Real=56402,0,14,947
TControl.ChangeBounds test(5):TATScroll Old=23006,0,14,466 New=56402,0,14,947 Real=56402,0,14,947
TControl.ChangeBounds test(6):TATScroll Old=23006,0,14,466 New=56402,0,14,947 Real=56402,0,14,947
ERROR in code: TGtk2WidgetSet.CreateBitmapFromRawImage Incompatible DataSize
Creating gdb catchable error:

  $00000000005A5029
  $00000000005A04C5
  $00000000006CA24D
  $0000000000544566
  $00000000005FB4B9
  $00000000006059F5
  $000000000060B4F5
  $000000000060EE1E
  $000000000061934B
TRasterImage.BitmapHandleNeeded: Unable to create handles, using default
The program 'cudatext' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 4673 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
  1. How do you run Cudatext? via Applications menu of Ubuntu?

Yes, via the applications menu.

@shamilchoudhury

This comment has been minimized.

Copy link
Author

@shamilchoudhury shamilchoudhury commented Oct 19, 2018

  1. Try to write to settings/user.json (in other editor)
    "pylib__linux": "ddd",

Tried. getting the same error I guess

ERROR in code: TGtk2WidgetSet.CreateBitmapFromRawImage Incompatible DataSize
Creating gdb catchable error:

  $00000000005A5029
  $00000000005A04C5
  $00000000006CA24D
  $0000000000544566
  $00000000005FB4B9
  $00000000006059F5
  $000000000060B4F5
  $000000000060EE1E
  $000000000061934B
TRasterImage.BitmapHandleNeeded: Unable to create handles, using default
ERROR in code: TGtk2WidgetSet.CreateBitmapFromRawImage Incompatible DataSize
Creating gdb catchable error:

  $00000000005A5029
  $00000000005A04C5
  $00000000006CA24D
  $0000000000544566
  $00000000005FB4B9
  $00000000006059F5
  $000000000060B4F5
  $000000000060EE1E
  $000000000061934B
TRasterImage.BitmapHandleNeeded: Unable to create handles, using default
TControl.ChangeBounds test(1):TATScroll Old=23006,0,14,466 New=56402,0,14,947 Real=56402,0,14,947
TControl.ChangeBounds test(2):TATScroll Old=23006,0,14,466 New=56402,0,14,947 Real=56402,0,14,947
TControl.ChangeBounds test(3):TATScroll Old=23006,0,14,466 New=56402,0,14,947 Real=56402,0,14,947
TControl.ChangeBounds test(4):TATScroll Old=23006,0,14,466 New=56402,0,14,947 Real=56402,0,14,947
TControl.ChangeBounds test(5):TATScroll Old=23006,0,14,466 New=56402,0,14,947 Real=56402,0,14,947
TControl.ChangeBounds test(6):TATScroll Old=23006,0,14,466 New=56402,0,14,947 Real=56402,0,14,947
WARNING: TfmMain.Destroy with LCLRefCount>0. Hint: Maybe the component is processing an event?

@Alexey-T

This comment has been minimized.

Copy link
Owner

@Alexey-T Alexey-T commented Oct 19, 2018

The error was 'BadAlloc (insufficient resources for operation)'.
seems you have low memory for Cud process? high memory load.

@shamilchoudhury

This comment has been minimized.

Copy link
Author

@shamilchoudhury shamilchoudhury commented Oct 19, 2018

The error was 'BadAlloc (insufficient resources for operation)'.
seems you have low memory for Cud process? high memory load.

Did a quick free -h

              total        used        free      shared  buff/cache   available
Mem:            15G        1.2G         11G        330M        2.5G         13G
Swap:            0B          0B          0B

and started Cuda, unfortunately same problem :(

@Alexey-T

This comment has been minimized.

Copy link
Owner

@Alexey-T Alexey-T commented Oct 19, 2018

Im confused, don't know what is the reason (some Lazarus bug?)
Can you try QT4 version of Cud?

@Alexey-T

This comment has been minimized.

@shamilchoudhury

This comment has been minimized.

Copy link
Author

@shamilchoudhury shamilchoudhury commented Oct 19, 2018

Im confused, don't know what is the reason (some Lazarus bug?)
Can you try QT4 version of Cud?

Sure. Let me try that.

@shamilchoudhury

This comment has been minimized.

Copy link
Author

@shamilchoudhury shamilchoudhury commented Oct 19, 2018

Can you try QT4 version of Cud?

is there any .deb available or should I build from source?

@Alexey-T

This comment has been minimized.

Copy link
Owner

@Alexey-T Alexey-T commented Oct 19, 2018

Package .tar.xz is available on CudaText.sf.net.
https://sourceforge.net/projects/cudatext/files/release/Linux/

@shamilchoudhury

This comment has been minimized.

Copy link
Author

@shamilchoudhury shamilchoudhury commented Oct 19, 2018

Qt4 version seems to be running without any issues so far ¯_(ツ)_/¯

@Alexey-T

This comment has been minimized.

Copy link
Owner

@Alexey-T Alexey-T commented Oct 19, 2018

Must be an issue in Lazarus gtk2 code

@Alexey-T

This comment has been minimized.

Copy link
Owner

@Alexey-T Alexey-T commented Oct 19, 2018

from Lazarus forum:
I doubt that is a Lazarus issue. It seems likely a GtK2 issue or a system specific issue.
And is Gtk2 actually installed on that machine? E.g. not Kubuntu?

@shamilchoudhury

This comment has been minimized.

Copy link
Author

@shamilchoudhury shamilchoudhury commented Oct 19, 2018

I'm running Xubuntu .

Tried apt-cache policy libgtk2.0-0 libgtk-3-0 . Here's the libraries:

libgtk2.0-0:
  Installed: 2.24.30-1ubuntu1.16.04.2
  Candidate: 2.24.30-1ubuntu1.16.04.2
  Version table:
 *** 2.24.30-1ubuntu1.16.04.2 500
        500 http://in.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2.24.30-1ubuntu1 500
        500 http://in.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
libgtk-3-0:
  Installed: 3.18.9-1ubuntu3.3
  Candidate: 3.18.9-1ubuntu3.3
  Version table:
 *** 3.18.9-1ubuntu3.3 500
        500 http://in.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     3.18.9-1ubuntu3 500
        500 http://in.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
@Alexey-T

This comment has been minimized.

Copy link
Owner

@Alexey-T Alexey-T commented Oct 20, 2018

Updated Cud to 1.64.0.4 with bugfix for filetypes-config...
don't know if its the case.

@Alexey-T

This comment has been minimized.

Copy link
Owner

@Alexey-T Alexey-T commented Oct 23, 2018

@Alexey-T

This comment has been minimized.

Copy link
Owner

@Alexey-T Alexey-T commented Oct 23, 2018

Xubuntu is OK here, no crash.

@shamilchoudhury

This comment has been minimized.

Copy link
Author

@shamilchoudhury shamilchoudhury commented Oct 24, 2018

Xubuntu is OK here, no crash.

Tested with cudatext_1.64.2.0-1_gtk2_amd64.deb . Same access violation error coming.

@Alexey-T

This comment has been minimized.

Copy link
Owner

@Alexey-T Alexey-T commented Oct 24, 2018

Can you test on clean Xubuntu (URL above) in VM?
seems, some OS packages issue, maybe gtk2 issue.

@shamilchoudhury

This comment has been minimized.

Copy link
Author

@shamilchoudhury shamilchoudhury commented Oct 24, 2018

Can you test on clean Xubuntu (URL above) in VM?
seems, some OS packages issue, maybe gtk2 issue.

okay

@Alexey-T

This comment has been minimized.

Copy link
Owner

@Alexey-T Alexey-T commented Oct 27, 2018

no feedback, so I can close.

@Alexey-T Alexey-T closed this Oct 29, 2018
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.