Skip to content
Browse files

Use new versioning & avoid import in setup.py

  • Loading branch information...
1 parent dfc72f9 commit 61af41ddb73c9e3b0b36fb1975417eb89101114f @Almad committed Aug 3, 2010
Showing with 15 additions and 6 deletions.
  1. +8 −2 setup.py
  2. +7 −4 sneakylang/__init__.py
View
10 setup.py
@@ -16,15 +16,21 @@
from distutils.command.install import INSTALL_SCHEMES
import sys
-import sneakylang
required_python_version = '2.4'
###############################################################################
# arguments for the setup command
###############################################################################
+
+
+VERSION = (0, 3, 1)
+
+__version__ = VERSION
+__versionstr__ = '.'.join(map(str, VERSION))
+
name = "sneakylang"
-version = sneakylang.__versionstr__
+version = __versionstr__
desc = "Extensible framework for easy creation of extensible WikiLanguages"
long_desc = """"""
classifiers=[
View
11 sneakylang/__init__.py
@@ -2,10 +2,13 @@
""" SneakyLang: Extensible WikiFramework """
-__version__ = [0, 3, 1, "dev"]
-__versionstr__ = "0.3.1-dev"
+VERSION = (0, 3, 1)
+
+__version__ = VERSION
+__versionstr__ = '.'.join(map(str, VERSION))
+
+
-from document import Document
from expanders import expand
from macro import Macro
from parser import parse
@@ -15,4 +18,4 @@
__all__ = (
"Document", "Macro", "Register", "RegisterMap", "TreeBuilder",
"parse", "expand",
-)
+)

0 comments on commit 61af41d

Please sign in to comment.
Something went wrong with that request. Please try again.