New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Test net::test::client_server_send fails: Networking packets get stuck somewhere between peers when connecting using normal means #10

Closed
Ameliorate opened this Issue Mar 6, 2016 · 2 comments

Comments

Projects
None yet
1 participant
@Ameliorate
Copy link
Owner

Ameliorate commented Mar 6, 2016

---- net::test::client_server_send stdout ----
    thread 'net::test::client_server_send' panicked at 'old_test_val < new_test_val, old_test_val: 0, new_test_val: 0', src/net/test.rs:59

It seems to be that the test packet is not sending. Further debugging is needed to determine if it is just the test packet or all packets.

@Ameliorate Ameliorate added the bug label Mar 6, 2016

@Ameliorate

This comment has been minimized.

Copy link
Owner

Ameliorate commented Mar 25, 2016

What I know:

  • All packets are not sending when connecting using mio infrastructure.
  • When not using the Client::spawn_client constructor like in event_loop_impl_send, things work.
  • Perhaps something set on the socket is causing issues.
  • The socket is never readable in the mio event loop.

@Ameliorate Ameliorate changed the title Test net::test::client_server_send fails Test net::test::client_server_send fails: Networking packets get stuck somewhere between peers when connecting using normal means Apr 4, 2016

@Ameliorate

This comment has been minimized.

Copy link
Owner

Ameliorate commented Apr 20, 2016

Fixed because of net nuke.

@Ameliorate Ameliorate closed this Apr 20, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment