Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add 'cppunit' as a build requiriment in the readme/wiki #1328

Closed
f-florian opened this issue Jun 5, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@f-florian
Copy link

commented Jun 5, 2019

It appears that building rtags needs cppunit, which, at least on Gentoo, is a separate package.
I think that it is also a separate package in Debian, though it may be pulled by some other dependency there.

May be related to #1221, which is however marked as fixed, and reported for macOS.

Details:
The call to cmake produces the following error:
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:137 (message): Could NOT find CPPUNIT (missing: CPPUNIT_LIBRARY CPPUNIT_INCLUDE_DIR) Call Stack (most recent call first): /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE) src/rct/tests/FindCPPUNIT.cmake:21 (find_package_handle_standard_args) src/rct/tests/CMakeLists.txt:6 (find_package)

Environment:

  • OS/Version: Gentoo
  • RTags(rdm,rc): github 'master' branch source
  • Emacs: n.a.
  • LLVM/Clang: 8.0.0
@cslux

This comment has been minimized.

Copy link
Collaborator

commented Jun 24, 2019

This shouldn't be required for a regular user. Only for packagers or devs. I will remove this dependency.

cslux added a commit that referenced this issue Jun 24, 2019

@cslux cslux closed this in 3c07131 Jun 24, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.