Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[WORKAROUND] HotReload does not work on the latest VS for Mac update 8.2 #102

Closed
iamlawrencev opened this issue Jul 25, 2019 · 6 comments

Comments

@iamlawrencev
Copy link

commented Jul 25, 2019

I installed the Visual Studio 8.2 for Mac update and suddenly HotReload does not work both on iOS and Android. The application output does not report any errors regarding HotReload.

XF Version: 4.1.0.555618

@AndreiMisiukevich

This comment has been minimized.

Copy link
Owner

commented Jul 25, 2019

Have you tried to restart VS after installation?
also have you enabled extension ?

@ChasakisD

This comment has been minimized.

Copy link
Contributor

commented Jul 25, 2019

I am having the exact same issue with VS for Mac 8.2. The issue is probably with the new XAML Editor. If you open a xaml file by Open With -> Source Code Editor, the file opens with the old editor, and then the extension is working great.

@iamlawrencev

This comment has been minimized.

Copy link
Author

commented Jul 25, 2019

@AndreiMisiukevich yes I have restarted and enabled extension. As @ChasakisD said this is most likely due to the new XAML editor. Thanks for the workaround @ChasakisD!

@iamlawrencev iamlawrencev changed the title HotReload does not work on the latest VS for Mac update HotReload does not work on the latest VS for Mac update 8.2 Jul 25, 2019
@AndreiMisiukevich AndreiMisiukevich changed the title HotReload does not work on the latest VS for Mac update 8.2 [WORKAROUND] HotReload does not work on the latest VS for Mac update 8.2 Jul 25, 2019
@AndreiMisiukevich

This comment has been minimized.

Copy link
Owner

commented Jul 25, 2019

Hmmm, thanks guys. Need to check what a hell is going on

@Saccomani

This comment has been minimized.

Copy link

commented Jul 29, 2019

I am having the exact same issue with VS for Mac 8.2. The issue is probably with the new XAML Editor. If you open a xaml file by Open With -> Source Code Editor, the file opens with the old editor, and then the extension is working great.

this workaround works fine to me !

AndreiMisiukevich added a commit that referenced this issue Jul 29, 2019
@AndreiMisiukevich

This comment has been minimized.

Copy link
Owner

commented Jul 29, 2019

download 1.4.0 extension version

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.