New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Opal.compile is not a function #3

Closed
parasquid opened this Issue Feb 5, 2016 · 3 comments

Comments

Projects
None yet
2 participants
@parasquid

parasquid commented Feb 5, 2016

I wanted to start using Opal v0.8.1 in order to be able to use named parameters (see opal/opal#678)

It gives me an error like this:

Uncaught TypeError: Opal.compile is not a function
$.extend.compile @ opalbox-jquery.min.js:10
$.extend.execute @ opalbox-jquery.min.js:10
(anonymous function) @ opalbox-jquery.min.js:10
m.event.dispatch @ jquery-1.11.3.min.js:4
r.handle @ jquery-1.11.3.min.js:4

Changing Opal back to 0.7.1 makes the plugin work again.

Will opalbox be supporting later versions of Opal?

@Angelmmiguel Angelmmiguel added the feature label Feb 5, 2016

@Angelmmiguel Angelmmiguel added this to the v1.0.0 milestone Feb 5, 2016

@Angelmmiguel Angelmmiguel self-assigned this Feb 5, 2016

@Angelmmiguel

This comment has been minimized.

Show comment
Hide comment
@Angelmmiguel

Angelmmiguel Feb 5, 2016

Owner

Hello @parasquid,

Yes, to update Opal to last stable version is the feature to set this library in v1.0.0. I will check how to import modules in new Opal versions.

Thanks!

Owner

Angelmmiguel commented Feb 5, 2016

Hello @parasquid,

Yes, to update Opal to last stable version is the feature to set this library in v1.0.0. I will check how to import modules in new Opal versions.

Thanks!

@Angelmmiguel

This comment has been minimized.

Show comment
Hide comment
@Angelmmiguel

Angelmmiguel Feb 5, 2016

Owner

I modify the way to load Opal modules in the library. I only need to test it :)

Owner

Angelmmiguel commented Feb 5, 2016

I modify the way to load Opal modules in the library. I only need to test it :)

@Angelmmiguel

This comment has been minimized.

Show comment
Hide comment
@Angelmmiguel

Angelmmiguel Feb 5, 2016

Owner

Done! Update the library to the last version. I set the version in the README to last stable version:

<!-- JS Dependencies (You can use CDN or local files) -->
<script type="text/javascript" src="http://cdn.opalrb.org/opal/0.8.1/opal.min.js"></script>
<script type="text/javascript" src="http://cdn.opalrb.org/opal/0.8.1/opal-parser.min.js"></script>
<script type="text/javascript" src="https://code.jquery.com/jquery-1.11.3.min.js"></script>
<!-- JS File -->
<script type="text/javascript" src="<route to opalbox.jquery.min.js>"></script>

However, I think you can use opalbox.jquery 1.0.0 with newer beta versions of Opal.rb libraries.

Owner

Angelmmiguel commented Feb 5, 2016

Done! Update the library to the last version. I set the version in the README to last stable version:

<!-- JS Dependencies (You can use CDN or local files) -->
<script type="text/javascript" src="http://cdn.opalrb.org/opal/0.8.1/opal.min.js"></script>
<script type="text/javascript" src="http://cdn.opalrb.org/opal/0.8.1/opal-parser.min.js"></script>
<script type="text/javascript" src="https://code.jquery.com/jquery-1.11.3.min.js"></script>
<!-- JS File -->
<script type="text/javascript" src="<route to opalbox.jquery.min.js>"></script>

However, I think you can use opalbox.jquery 1.0.0 with newer beta versions of Opal.rb libraries.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment