Skip to content
Browse files

Merge pull request #2 from kraj/master

angstrom-next changesets
  • Loading branch information...
2 parents 140671a + f5b657c commit 52a1a600ed44e79736a5105f2af06299e20f25d9 @koenkooi koenkooi committed
View
32 conf/distro/angstrom-v2012.x.conf → conf/distro/angstrom-next.conf
@@ -19,15 +19,13 @@
# Again, in doubt, use the master branch of setup-scripts
#DISTRO_VERSION = "v2012.X"
-DISTRO_VERSION = "v${@time.strftime('%Y.%m',time.gmtime())}-core"
-DISTRO_REVISION = "5"
-DISTRO_PR = ".11"
+DISTRO_VERSION = "v${@time.strftime('%Y.%m',time.gmtime())}"
OLDEST_KERNEL = "2.6.16"
require conf/distro/include/sane-srcdates.inc
require conf/distro/include/sane-srcrevs.inc
-require conf/distro/include/angstrom-2010-preferred-versions.inc
+require conf/distro/include/angstrom-preferred-versions.inc
#Images built can have to modes:
# 'debug': empty rootpassword, strace included
@@ -53,21 +51,14 @@ IMAGE_LINGUAS ?= '${@base_less_or_equal("ROOT_FLASH_SIZE", "16", "", "en-us", d)
FEED_BASEPATH = "feeds/core/${ANGSTROM_PKG_FORMAT}/${TCLIBC}/"
#This is unrelated to the kernel version, but userspace apps (e.g. udev/systemd) require a recent version to build against
-LINUX_LIBC_HEADERS_VERSION ?= "3.2"
+LINUX_LIBC_HEADERS_VERSION ?= "3.4%"
PREFERRED_VERSION_linux-libc-headers = "${LINUX_LIBC_HEADERS_VERSION}"
PREFERRED_VERSION_linux-libc-headers-native = "${LINUX_LIBC_HEADERS_VERSION}"
PREFERRED_VERSION_linux-libc-headers-nativesdk = "${LINUX_LIBC_HEADERS_VERSION}"
-ANGSTROM_EGLIBC_VERSION ?= "2.15"
-ANGSTROM_GLIBC_VERSION ?= "2.10.1"
-ANGSTROM_UCLIBC_VERSION ?= "0.9.33"
-
-#Prefer glibc 2.6 and uclibc 0.9.30, these have had the most testing.
-PREFERRED_VERSION_glibc ?= "${ANGSTROM_GLIBC_VERSION}"
-PREFERRED_VERSION_glibc-initial ?= "${ANGSTROM_GLIBC_VERSION}"
-PREFERRED_VERSION_glibc-nativesdk ?= "${ANGSTROM_GLIBC_VERSION}"
-PREFERRED_VERSION_glibc-initial-nativesdk = "${ANGSTROM_GLIBC_VERSION}"
+ANGSTROM_EGLIBC_VERSION ?= "2.16"
+ANGSTROM_UCLIBC_VERSION ?= "0.9.33+git%"
PREFERRED_VERSION_uclibc ?= "${ANGSTROM_UCLIBC_VERSION}"
PREFERRED_VERSION_uclibc-initial ?= "${ANGSTROM_UCLIBC_VERSION}"
@@ -123,13 +114,12 @@ PREFERRED_PROVIDER_opkg ?= "opkg"
PREFERRED_PROVIDER_opkg-native ?= "opkg-native"
PREFERRED_PROVIDER_udev = "systemd"
-ANGSTROM_BLACKLIST_pn-fso-apm = "regular apmd is good enough"
-
-ANGSTROM_BLACKLIST_pn-gconf-dbus = "gconf-dbus has been merged back into main GConf"
-ANGSTROM_BLACKLIST_pn-gconf-dbus-native = "gconf-dbus has been merged back into main GConf"
-
-ANGSTROM_BLACKLIST_pn-ffmpeg = "libav is preferred over ffmpeg"
+# blacklist policy
+PNBLACKLIST[pn-fso-apm] = "regular apmd is good enough"
+PNBLACKLIST[gconf-dbus] = "gconf-dbus has been merged back into main GConf"
+PNBLACKLIST[gconf-dbus-native] = "gconf-dbus has been merged back into main GConf"
+PNBLACKLIST[ffmpeg] = "libav is preferred over ffmpeg"
require conf/distro/include/angstrom.inc
@@ -194,7 +184,7 @@ DISTRO_EXTRA_RRECOMMENDS += " \
SPLASH ?= ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-angstrom", "",d)}'
DISTRO_FEATURES += "${LDISGOLD}"
-LDISGOLD_arm = "ld-is-gold"
+#LDISGOLD_arm = "ld-is-gold"
LDISGOLD_x86 = "ld-is-gold"
LDISGOLD_x86_64 = "ld-is-gold"
LDISGOLD = ""
View
2 conf/distro/include/angstrom-eglibc.inc
@@ -1,5 +1,5 @@
# eglibc:
-ANGSTROM_BLACKLIST_pn-libiconv = "the eglibc provided iconv library is used"
+PNBLACKLIST[libiconv] = "the eglibc provided iconv library is used"
TARGET_OS = "linux"
View
2 conf/distro/include/angstrom-glibc.inc
@@ -1,7 +1,7 @@
# glibc:
require conf/distro/include/glibc-${TOOLCHAIN_TYPE}.inc
-ANGSTROM_BLACKLIST_pn-libiconv = "the glibc provided iconv library is used"
+PNBLACKLIST[libiconv] = "the glibc provided iconv library is used"
TARGET_OS = "linux"
TARGET_OS .= "${@['','-gnueabi'][bb.data.getVar('TARGET_ARCH',d,1) in ['arm', 'armeb']]}"
View
0 ...lude/angstrom-2010-preferred-versions.inc → ...o/include/angstrom-preferred-versions.inc
File renamed without changes.
View
1 conf/distro/include/toolchain-external.inc
@@ -1,7 +1,6 @@
# Toolchain specific virtuals
PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}binutils = "external-toolchain-${TOOLCHAIN_BRAND}"
PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}gcc-initial = "external-toolchain-${TOOLCHAIN_BRAND}"
-PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}gcc-intermediate = "external-toolchain-${TOOLCHAIN_BRAND}"
PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}gcc = "external-toolchain-${TOOLCHAIN_BRAND}"
PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}g++ = "external-toolchain-${TOOLCHAIN_BRAND}"
#PREFERRED_PROVIDER_linux-libc-headers = "external-toolchain-${TOOLCHAIN_BRAND}"
View
1 conf/distro/include/toolchain-internal.inc
@@ -1,7 +1,6 @@
# Toolchain specific virtuals
PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}binutils = "binutils-cross"
PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}gcc-initial = "gcc-cross-initial"
-PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}gcc-intermediate = "gcc-cross-intermediate"
PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}gcc = "gcc-cross"
PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}g++ = "gcc-cross"
PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}compilerlibs = "gcc-runtime"
View
3 recipes-devtools/meta/external-toolchain-angstrom.bb
@@ -1,4 +1,4 @@
-PR = "r1"
+PR = "r2"
INHIBIT_DEFAULT_DEPS = "1"
@@ -17,7 +17,6 @@ PROVIDES = "\
virtual/${TARGET_PREFIX}gcc \
virtual/${TARGET_PREFIX}g++ \
virtual/${TARGET_PREFIX}gcc-initial \
- virtual/${TARGET_PREFIX}gcc-intermediate \
virtual/${TARGET_PREFIX}binutils \
virtual/${TARGET_PREFIX}libc-for-gcc \
virtual/${TARGET_PREFIX}libc-initial \

0 comments on commit 52a1a60

Please sign in to comment.
Something went wrong with that request. Please try again.