Permalink
Browse files

oebb: check for outdated 'git' binary

Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
  • Loading branch information...
1 parent fd8a2ed commit 801fd1fa78d0068f0fcef8d69a2250949f8c79cd @koenkooi koenkooi committed Apr 20, 2012
Showing with 6 additions and 0 deletions.
  1. +6 −0 oebb.sh
View
6 oebb.sh
@@ -37,6 +37,12 @@ OE_BASE=${PWD}
BASE_VERSION=5
OE_ENV_FILE=~/.oe/environment-angstromv2012.05
+if ! git help log | grep -q no-abbrev ; then
+ echo "Your installed version of git is too old, it lacks --no-abbrev-commit. Please install 1.7.6 or newer"
+ exit 1
+fi
+
+
###############################################################################
# CONFIG_OE() - Configure OpenEmbedded
###############################################################################

0 comments on commit 801fd1f

Please sign in to comment.