Skip to content

Loading…

Development dependecies should be standard dependecies #78

Closed
Systho opened this Issue · 3 comments

2 participants

@Systho

in the gemspec, the following bloc

  s.add_development_dependency "rspec-rails"
  s.add_development_dependency "rails", ">= 3.0.10"
  s.add_development_dependency "sqlite3"
  s.add_development_dependency "minitest"
  s.add_development_dependency "maruku"
  s.add_development_dependency "RedCloth"
  s.add_development_dependency "rake"
  s.add_development_dependency "rest-client"
  s.add_development_dependency "oauth"

should be replaced by

  s.add_development_dependency "rspec-rails"
  s.add_dependency "rails", ">= 3.0.10"
  s.add_development_dependency "sqlite3"
  s.add_development_dependency "minitest"
  s.add_dependency "maruku"
  s.add_dependency "RedCloth"
  s.add_development_dependency "rake"
  s.add_dependency "rest-client"
  s.add_dependency "oauth"

since most of those gems are production dependecies and not dev dependecies

@Systho

I'm not sure about maruku and RedCloth, though.
The readme clearly states that those gems are optional so I guess they can stay dev dependencies

@iNecas
Apipie member

That's right, rest-client and oauth can be removed completly since #74, I agree with rails dep.

@iNecas iNecas referenced this issue
Merged

Fix gemspec deps #79

@iNecas
Apipie member

New release 0.0.14 shouldn't have the problems with implicit oauth and rest-client deps. Closing. Please reopen if needed

@iNecas iNecas closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.