New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Apple Win problem with Double Lores and Aux-Move #516

Closed
naspitelabs opened this Issue Dec 3, 2017 · 9 comments

Comments

Projects
None yet
2 participants
@naspitelabs

naspitelabs commented Dec 3, 2017

When one has a Double Lores image on the screen, and then you do an aux move (The direction I usually go in is from Main to Aux memory), it will switch the onscreen display from DBLORES pg1 to DBLORES pg2. On real hardware it will do this switch (On a IIE Plat and GSSport works)... but in Apple WIN it does not do this (Its sort of a reverse glitch). Once I do aux-move, I perform POKE 49152,0:POKE 49236,0 to change it back to the original screen, so I think these memory locations are (NOT) changed with applewin to create hardware like conditions. ((((-As a side note, Apple WIN 1.25.0.3 is great for programming with its display mode in COLOR-TV, and i know the color is slightly off in comparison to the newer version.. but the new one is so hard to use on a daily basis for programming and has a fuzzy display. Regardless, AppleWIN is fantastic software, thank your for making it!)

@tomcw

This comment has been minimized.

Show comment
Hide comment
@tomcw

tomcw Dec 3, 2017

Contributor

As a side note, Apple WIN 1.25.0.3 is great for programming with its display mode in COLOR-TV, and i know the color is slightly off in comparison to the newer version.. but the new one is so hard to use on a daily basis for programming and has a fuzzy display.

Another vote for #357. But duly noted.

Regardless, AppleWIN is fantastic software, thank your for making it!

Thanks for the feedback! :)

Contributor

tomcw commented Dec 3, 2017

As a side note, Apple WIN 1.25.0.3 is great for programming with its display mode in COLOR-TV, and i know the color is slightly off in comparison to the newer version.. but the new one is so hard to use on a daily basis for programming and has a fuzzy display.

Another vote for #357. But duly noted.

Regardless, AppleWIN is fantastic software, thank your for making it!

Thanks for the feedback! :)

@tomcw

This comment has been minimized.

Show comment
Hide comment
@tomcw

tomcw Dec 3, 2017

Contributor

When one has a Double Lores image on the screen, and then you do an aux move (The direction I usually go in is from Main to Aux memory), it will switch the onscreen display from DBLORES pg1 to DBLORES pg2.

You say you are using AppleWin 1.25.0.3.
Does this also occur with AppleWin 1.26.3.4 too?

Contributor

tomcw commented Dec 3, 2017

When one has a Double Lores image on the screen, and then you do an aux move (The direction I usually go in is from Main to Aux memory), it will switch the onscreen display from DBLORES pg1 to DBLORES pg2.

You say you are using AppleWin 1.25.0.3.
Does this also occur with AppleWin 1.26.3.4 too?

@naspitelabs

This comment has been minimized.

Show comment
Hide comment
@naspitelabs

naspitelabs Dec 3, 2017

Yes, when the issue was first discovered, I went to download the latest version (1.26.xx something) and the same issue existed.. its a pain switching between GSSport and AppleWin to determine exactly what the issue (minimum code is)... i'm trying to get you a disk image... when run on real hardware it will glitch on the screen, in AppleWin, everything seems normal... very deceiving!

naspitelabs commented Dec 3, 2017

Yes, when the issue was first discovered, I went to download the latest version (1.26.xx something) and the same issue existed.. its a pain switching between GSSport and AppleWin to determine exactly what the issue (minimum code is)... i'm trying to get you a disk image... when run on real hardware it will glitch on the screen, in AppleWin, everything seems normal... very deceiving!

@naspitelabs

This comment has been minimized.

Show comment
Hide comment
@naspitelabs

naspitelabs Dec 4, 2017

https://www.dropbox.com/s/uvhmyf32ikevvjr/DLORES%20GLITCH.dsk?dl=0
This file... TEST1 will produce graphic glitch in GSSport and IIE Plat (*This is what its suppose to do), but will be fine in AppleWin. Test2 will be fine in all cases. Note line 199 is what I did to 'correct' the issue, it pretty much reactivates pg1 of double lores after an aux move operation. CALL 36600 activates double-lores... 37190 is the double lores page mover... you can again place it in a new statement like 407 (407 call 36600:call 37190) if you want to see the second image, but is not needed for the glitch to occur.

naspitelabs commented Dec 4, 2017

https://www.dropbox.com/s/uvhmyf32ikevvjr/DLORES%20GLITCH.dsk?dl=0
This file... TEST1 will produce graphic glitch in GSSport and IIE Plat (*This is what its suppose to do), but will be fine in AppleWin. Test2 will be fine in all cases. Note line 199 is what I did to 'correct' the issue, it pretty much reactivates pg1 of double lores after an aux move operation. CALL 36600 activates double-lores... 37190 is the double lores page mover... you can again place it in a new statement like 407 (407 call 36600:call 37190) if you want to see the second image, but is not needed for the glitch to occur.

tomcw added a commit that referenced this issue Dec 4, 2017

@tomcw

This comment has been minimized.

Show comment
Hide comment
@tomcw

tomcw Dec 4, 2017

Contributor

Thanks for the repro. This bug has been latent for many years.
I'll rebuild and get you to verify the fix...

Contributor

tomcw commented Dec 4, 2017

Thanks for the repro. This bug has been latent for many years.
I'll rebuild and get you to verify the fix...

@tomcw

This comment has been minimized.

Show comment
Hide comment
@tomcw

tomcw Dec 4, 2017

Contributor

Can you try AppleWin v1.26.3.5 and let me know how you get on?

Note to self: "a2audit 1.04" noticeably more flickery now, but otherwise all tests appear fine.

Contributor

tomcw commented Dec 4, 2017

Can you try AppleWin v1.26.3.5 and let me know how you get on?

Note to self: "a2audit 1.04" noticeably more flickery now, but otherwise all tests appear fine.

@tomcw tomcw self-assigned this Dec 4, 2017

@tomcw tomcw added the bug label Dec 4, 2017

@tomcw

This comment has been minimized.

Show comment
Hide comment
@tomcw

tomcw Dec 13, 2017

Contributor

@naspitelabs - please let me know if AppleWin v1.26.3.5 fixes the issue? Thanks.

Contributor

tomcw commented Dec 13, 2017

@naspitelabs - please let me know if AppleWin v1.26.3.5 fixes the issue? Thanks.

@naspitelabs

This comment has been minimized.

Show comment
Hide comment
@naspitelabs

naspitelabs Dec 13, 2017

naspitelabs commented Dec 13, 2017

@tomcw

This comment has been minimized.

Show comment
Hide comment
@tomcw

tomcw Dec 16, 2017

Contributor

Thanks for confirming.

Contributor

tomcw commented Dec 16, 2017

Thanks for confirming.

@tomcw tomcw closed this Dec 16, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment