Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unable to type certain characters when AltGr is required on an international keyboard #625

Closed
tomcw opened this issue Feb 26, 2019 · 5 comments

Comments

Projects
None yet
2 participants
@tomcw
Copy link
Contributor

commented Feb 26, 2019

Spun off from #583, reported by @tilleul:


Sorry if it's not related to the issue I have but to me it's very similar. Using v1.28...
Using a french-keyboard, I'm unable to print characters like @ # { } in APPLESOFT ! ... these require ALT GR on a french keyboard ....

What is strange is that: printing [ ] work although they also require ALT GR
What's even stranger is that printing § or £ does not work either although it does NOT require ALT GR !

I don't have the problem with v1.26. Tested on 2 computers, same result.

I have tried using the -no-hook-alt ... it doesn't change anything ...

@tomcw

This comment has been minimized.

Copy link
Contributor Author

commented Feb 26, 2019

1.27.5 works.
1.27.6 doesn't ...

Probably this commit 6ed3547 is the problem, ie. for #558.

For reference, Alt Gr on a French keyboard: https://en.wikipedia.org/wiki/AltGr_key#French
EG. AltGr+0 -> @

Maybe enable this behaviour only on a cmd-line switch - no one was asking for this anyway, it was just something I spotted.

@tilleul

This comment has been minimized.

Copy link

commented Feb 27, 2019

Thanks. I don't know if it has any impact for you or not but my keyboard is in fact Belgian :)
So for me it's ALTGR+2 -> @ and ALTGR+3 -> # but I suppose you'll find a fix common to all keyboards ?

@tomcw tomcw closed this in cd9a207 Mar 3, 2019

@tomcw

This comment has been minimized.

Copy link
Contributor Author

commented Mar 3, 2019

There's a new AppleWin 1.28.3 build here.

I've reverted the behaviour so it should be like 1.27.5.
Can you confirm this is working for you?

NB. There's a new command line switch to enable the 1.27.6 AltGr+<key> behaviour (-altgr-sends-wmchar). I guess only use this for US or UK keyboards?

@tilleul

This comment has been minimized.

Copy link

commented Mar 3, 2019

It's working ! Thanks !

@tomcw

This comment has been minimized.

Copy link
Contributor Author

commented Mar 3, 2019

Great! Thanks for confirming.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.