Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Draw error on storage monitor after minecraft reload #1673

Closed
datahunter opened this issue Jul 3, 2015 · 4 comments
Closed

Draw error on storage monitor after minecraft reload #1673

datahunter opened this issue Jul 3, 2015 · 4 comments
Labels

Comments

@datahunter
Copy link

@datahunter datahunter commented Jul 3, 2015

When I put items(from a few other mods) on the storage monitor it works fine until i leave minecraft and reload level then there are a few errors.. I found it is the same on two different systems and when I remove the item from the monitor and replace it it works fine,

before reload
ae_forestry

after reload
ae_draw error

draw error items shown i the air and not on terminal and some random molten iron in the air although there isn't any on the map
ae_draw error2

the ingot in the air is the one in the chest below me
ae_draw error3
ae_draw error4

and finally when I look at some monitors my screen goes blank
ae_draw error5

after I remove the item from the monitor everything is then back to normal and I can put the item back on the monitor with no draw error

log file
http://pastebin.com/3hWMxy8Q

@yueh
Copy link
Member

@yueh yueh commented Jul 4, 2015

Looks like a broken itemrenderer, but it seems to not appear with just forestry and AE2 alone.

I would also recommend to try it without any "optimizing" mod like Optifine, FastCraft, etc.
If this not fixes it, start a new instance just with AE2 and add the other mods slowly back until you find the one causing it.

@yueh yueh added the state-waiting label Jul 4, 2015
@datahunter
Copy link
Author

@datahunter datahunter commented Jul 4, 2015

I search further and found the problem with only 2 mods installed first I tested with only forestry and then with bibliocraft, I found when I put the item on the monitor with nothing in the me drive then it works fine even after restart, but when I put the item in ME drive the draw error begin after restart
2015-07-04_16 45 11
2015-07-04_16 38 14
2015-07-04_16 39 05
2015-07-04_16 37 48
2015-07-04_16 26 17
2015-07-04_16 27 21
if I break the cable so the me system is off then the draw error decrease and after restart the draw error is gone

all my mods are up to date and I tried with older version as well

@yueh
Copy link
Member

@yueh yueh commented Jul 4, 2015

Not sure about rv2, but at least rv3 has an issue with it.
At least AE2 + bibliocraft or forestry works fine for me.

@datahunter
Copy link
Author

@datahunter datahunter commented Jul 6, 2015

Is there a place where I can get rv3 to test it?

@yueh yueh closed this in #1678 Jul 14, 2015
@github-actions github-actions bot locked as resolved and limited conversation to collaborators Mar 29, 2020
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.