New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

build demo project with error: Unknown verification type [16] in stack map frame #11

Closed
yujiaao opened this Issue Feb 17, 2017 · 9 comments

Comments

Projects
None yet
6 participants
@yujiaao

yujiaao commented Feb 17, 2017

Error:Execution failed for task ':app:transformClassesWithMultidexlistForDebug'.

java.io.IOException: Can't read [/home/xxx/projects/AprilBeaconDemos/app/build/intermediates/transforms/jarMerging/debug/jars/1/1f/combined.jar] (Can't process class [com/aprilbrother/aprilbrothersdk/services/ABeaconUartService$1.class] (Unknown verification type [16] in stack map frame))

@syxdzc

This comment has been minimized.

Show comment
Hide comment
@syxdzc

syxdzc Feb 20, 2017

Contributor

Did you want to proguard the demo?
you can read the readme of the proguard
"if have this question (Can't process class com/aprilbrother/aprilbrothersdk/services/ABeaconUartService$1.class) repalce the proguard.jar"

Contributor

syxdzc commented Feb 20, 2017

Did you want to proguard the demo?
you can read the readme of the proguard
"if have this question (Can't process class com/aprilbrother/aprilbrothersdk/services/ABeaconUartService$1.class) repalce the proguard.jar"

@rongxuanhong

This comment has been minimized.

Show comment
Hide comment
@rongxuanhong

rongxuanhong May 19, 2017

I try to include the proguard.jar as file under libs, but it didn't work. The error remains. so upset!!

rongxuanhong commented May 19, 2017

I try to include the proguard.jar as file under libs, but it didn't work. The error remains. so upset!!

@syxdzc

This comment has been minimized.

Show comment
Hide comment
@syxdzc

syxdzc May 22, 2017

Contributor

your project is use android studio or eclipse?
ADT: replace sdk/tools/proguard/lib/proguard.jar
AS: replace android-studio/gradle/m2repository/net/sf/proguard/proguard-base/5.x/proguard-base-5.x.jar

Contributor

syxdzc commented May 22, 2017

your project is use android studio or eclipse?
ADT: replace sdk/tools/proguard/lib/proguard.jar
AS: replace android-studio/gradle/m2repository/net/sf/proguard/proguard-base/5.x/proguard-base-5.x.jar

@rongxuanhong

This comment has been minimized.

Show comment
Hide comment
@rongxuanhong

rongxuanhong May 22, 2017

First,the version of my android studio is 2.3,and gradle is 3.3,proguard-base is 5.3.2. Second,I follow your tips and change the proguard-base-5.2.jar(ps: I copy the proguard.jar and refactor its name to original name),but when I restart As and try to run this project, Failed again. the message is as follow.

Error:Execution failed for task ':app:transformClassesWithMultidexlistForDebug'.
proguard.KeepClassSpecification.(ZZZZZZLproguard/ClassSpecification;)V

I also try to search this problem, and it said that the version of android studio don't match that of proguad.jar. so I check your demo's gradle version, and I found it is 3.3 ,Thus,I'm confused again,why this happened ?.

rongxuanhong commented May 22, 2017

First,the version of my android studio is 2.3,and gradle is 3.3,proguard-base is 5.3.2. Second,I follow your tips and change the proguard-base-5.2.jar(ps: I copy the proguard.jar and refactor its name to original name),but when I restart As and try to run this project, Failed again. the message is as follow.

Error:Execution failed for task ':app:transformClassesWithMultidexlistForDebug'.
proguard.KeepClassSpecification.(ZZZZZZLproguard/ClassSpecification;)V

I also try to search this problem, and it said that the version of android studio don't match that of proguad.jar. so I check your demo's gradle version, and I found it is 3.3 ,Thus,I'm confused again,why this happened ?.

@syxdzc syxdzc closed this Jun 14, 2017

@dhaltmayer

This comment has been minimized.

Show comment
Hide comment
@dhaltmayer

dhaltmayer Jun 14, 2017

We are having this issue also. What was the solution, @syxdzc ?

dhaltmayer commented Jun 14, 2017

We are having this issue also. What was the solution, @syxdzc ?

@syxdzc

This comment has been minimized.

Show comment
Hide comment
@syxdzc

syxdzc Jun 15, 2017

Contributor

if have this question (Can't process class [com/aprilbrother/aprilbrothersdk/services/ABeaconUartService$1.class] (Unknown verification type [18] in stack map frame)) repalce the proguard.jar
ADT: replace sdk/tools/proguard/lib/proguard.jar
android studio: replace android-studio/gradle/m2repository/net/sf/proguard/proguard-base/5.x/proguard-base-5.x.jar
https://github.com/AprilBrother/AprilBeacon-Android-SDK#proguard

Contributor

syxdzc commented Jun 15, 2017

if have this question (Can't process class [com/aprilbrother/aprilbrothersdk/services/ABeaconUartService$1.class] (Unknown verification type [18] in stack map frame)) repalce the proguard.jar
ADT: replace sdk/tools/proguard/lib/proguard.jar
android studio: replace android-studio/gradle/m2repository/net/sf/proguard/proguard-base/5.x/proguard-base-5.x.jar
https://github.com/AprilBrother/AprilBeacon-Android-SDK#proguard

@rongxuanhong

This comment has been minimized.

Show comment
Hide comment
@rongxuanhong

rongxuanhong Jun 15, 2017

rongxuanhong commented Jun 15, 2017

@saturov

This comment has been minimized.

Show comment
Hide comment
@saturov

saturov Jun 15, 2017

@syxdzc we don't think that replacing Proguard with its tweaked outdated version is good to go. We need up-to-date clean Proguard for our project, but using your SDK we lose an ability to use it because of your library internal bug (I suppose so). Why can't you just fix it? Please, it's more than just important.

saturov commented Jun 15, 2017

@syxdzc we don't think that replacing Proguard with its tweaked outdated version is good to go. We need up-to-date clean Proguard for our project, but using your SDK we lose an ability to use it because of your library internal bug (I suppose so). Why can't you just fix it? Please, it's more than just important.

@xfeivip

This comment has been minimized.

Show comment
Hide comment
@xfeivip

xfeivip Oct 11, 2018

我也遇到同样的问题 求解啊

xfeivip commented Oct 11, 2018

我也遇到同样的问题 求解啊

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment