Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Rover: SITL gazebo long connection at initialisation #5615

Closed
khancyr opened this issue Jan 25, 2017 · 3 comments

Comments

@khancyr
Copy link
Contributor

commented Jan 25, 2017

Issue details

When using gazebo sitl with rover, it seems to be an important slow down in sitl or micro disconnection
that make launch very slow. The behaviour can be more or less long (but less that 1 min)

example ouput on mavproxy console

online system 1
Mode INITIALISING
fence breach
APM: APM:Rover v3.1.0 (6fc79923)
APM: Barometer calibration complete
APM: <startup_ground> Ground start
APM: Warming up ADC
APM: Initialising APM
APM: Beginning INS calibration. Do not move vehicle
Init Gyro***no link
link 1 down

APM: Ready to drive
link 1 OK
heartbeat OK
Mode MANUAL

Version

master

Platform

[ ] All
[ ] AntennaTracker
[ ] Copter
[ ] Plane
[ X ] Rover

@OXINARF OXINARF added ROS Rover labels Jan 25, 2017

@khancyr

This comment has been minimized.

Copy link
Contributor Author

commented Feb 16, 2017

Update: it seems to be a problem with the gyro calibration from the gyro model in gazebo ...

@khancyr

This comment has been minimized.

Copy link
Contributor Author

commented Mar 13, 2017

Solve on rover by setting 100000000 and 10000 on wheel. It dampers the calculated collision with the ground

@khancyr khancyr closed this Mar 13, 2017

@rajat2004

This comment has been minimized.

Copy link
Contributor

commented Sep 9, 2019

@khancyr Could you give a few more details on how you fixed this problem? I'm having a similar problem with Airsim
I couldn't find any parameter like this in the Gazebo or rover params or even in the complete param list

The output from my console is-

MAV> APM: Calibrating barometer
APM: ArduRover V3.6.0-dev (d9765a99)
APM: 30c79b4748134ec8b0cb95949b098e1b
Received 1079 parameters
Saved 1079 parameters to mav.parm
online system 1
INITIALISING> Mode INITIALISING
APM: Barometer 1 calibration complete
APM: <startup_ground> Ground start
APM: Beginning INS calibration. Do not move vehicle
Init Gyro***
APM: INS: alloc 6144 bytes for ISB (free=131072)
APM: Ready to drive
MANUAL> Mode MANUAL
APM: GPS 1: detected as u-blox at 115200 baud
APM: EKF2 IMU0 initial yaw alignment complete
APM: EKF2 IMU1 initial yaw alignment complete
APM: EKF2 IMU0 origin set
APM: EKF2 IMU1 origin set
APM: EKF2 IMU1 tilt alignment complete
no link
link 1 down
no link
no link

Disabling Gyro calibration with INS_GYR_CAL, EKF Type 10, disabling arming checks, disabling crash check using FS_CRASH_CHECK, nothing worked

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.