Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

wti 2.4.4 pull does not pull multiple files #142

Closed
dirkweinhardt opened this issue Dec 20, 2017 · 3 comments

Comments

@dirkweinhardt
Copy link

@dirkweinhardt dirkweinhardt commented Dec 20, 2017

In the context of migrating to a new CI server we have updated from webtranslateit 2.4.0 to 2.4.4. Since updating the wti command fails to pull multiple files.

With the old CI server with webtranslateit 2.4.0 we used to pull multiple files from WTI like this:

me@ci-old:~/my-project$ wti --version
wti version 2.4.0
me@ci-old:~/my-project$ wti pull app/lang/common-de.json app/lang/common-en.json app/lang/common-hu.json app/lang/common-it.json app/lang/common-cs.json app/lang/common-nl.json
# Pulling files on my-project
 app/lang/common-cs.json                            | ..70c2ecf  OK
 app/lang/common-hu.json                            | ..c3ebbd5  OK
 app/lang/common-de.json                            | ..3eeb70c  OK
 app/lang/common-it.json                            | ..c3ebbd5  OK
 app/lang/common-en.json                            | ..1fad41b  OK
 app/lang/common-nl.json                            | ..c3ebbd5  OK
Pulled 6 files at 21 files/sec, using 2 threads.

Now, on the new CI server with webtranslateit 2.4.4 installed the exact same command does not pull any file at all:

me@ci-new:~/my-project$ wti --version
wti version 2.4.4
me@ci-new:~/my-project$ wti pull app/lang/common-de.json app/lang/common-en.json app/lang/common-hu.json app/lang/common-it.json app/lang/common-cs.json app/lang/common-nl.json
# Pulling files on my-project
No files to pull.

Pulling each file individually does work with webtranslateit 2.4.4 so the general setup is OK:

me@ci-new:~/my-project$ wti --version
wti version 2.4.4
me@ci-new:~/my-project$ wti pull app/lang/common-de.json
# Pulling files on my-project
 app/lang/common-de.json                            | ..3eeb70c  OK
Pulled 1 files at 12 files/sec, using 1 threads.
me@ci-new:~/my-project$ wti pull app/lang/common-en.json
# Pulling files on my-project
 app/lang/common-en.json                            | ..1fad41b  OK
Pulled 1 files at 13 files/sec, using 1 threads.
@edouard edouard closed this in 6f6d641 Dec 21, 2017
@edouard

This comment has been minimized.

Copy link
Member

@edouard edouard commented Dec 21, 2017

Hi, thank you for reporting this issue. The bug is now fixed in the version 2.4.5 I just released.

@dirkweinhardt

This comment has been minimized.

Copy link
Author

@dirkweinhardt dirkweinhardt commented Dec 21, 2017

I can confirm with 2.4.5 pulling multiple files works again as it used to do. Thank you for the very quick help on this!

@edouard

This comment has been minimized.

Copy link
Member

@edouard edouard commented Dec 21, 2017

👍

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.