Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Upgrades for express 3.x #138

Merged
merged 1 commit into from

7 participants

@nathanbowser

If you're trying to use kue as a mounted app in an express 3 app, you're out of luck. This upgrades the kue express app to 3.x.

@rauchg
Owner

LGTM

@tj
tj commented

LGTMT I'll try it out afta work

@yrezgui

Is this pull request will be accepted ?

@tj tj merged commit 6339f1b into Automattic:master
@yrezgui

Thanks guys to answer so quickly :+1: !

@navkumar

Is there an ETA on when this will be available in npm? Seems it's still not there yet.

@Jellyfrog

npm install git://github.com/LearnBoost/kue.git

@tj
tj commented

seems like the style got fucked up

@ecarter

@Jellyfrog thx! exactly what I needed :beers:

Was attempting to mount kue via express (installed from npm) and not having the best of luck :goberserk:

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Oct 4, 2012
  1. @nathanbowser

    Upgrades for express 3.x

    nathanbowser authored
This page is out of date. Refresh to see the latest.
View
4 lib/http/index.js
@@ -13,7 +13,7 @@ var express = require('express');
// setup
-var app = express.createServer()
+var app = express()
, provides = require('./middleware/provides')
, stylus = require('stylus')
, routes = require('./routes')
@@ -39,7 +39,7 @@ app.set('view options', { doctype: 'html' });
app.set('view engine', 'jade');
app.set('views', __dirname + '/views');
app.set('title', 'Kue');
-app.helpers({ inspect: util.inspect });
+app.locals({ inspect: util.inspect })
// middleware
View
17 lib/http/views/job/list.jade
@@ -1,10 +1,13 @@
-h1 #{state}
+extends ../layout
-script
- o(function(){
- init('#{state}');
- });
+block body
+ h1 #{state}
+ script
+ o(function(){
+ init('#{state}');
+ });
-#jobs
-#loading: canvas(width=50, height=50)
+
+ #jobs
+ #loading: canvas(width=50, height=50)
View
17 lib/http/views/layout.jade
@@ -12,12 +12,15 @@ html
script(src='./javascripts/search.js')
script(src='./javascripts/main.js')
body
- != partial('menu')
+ include _menu
#actions
- != partial('search')
- != partial('filter')
- != partial('sort')
- #content!= body
- script(type='text/template')#job-template!= partial('job')
- script(type='text/template')#row-template!= partial('row')
+ include _search
+ include _filter
+ include _sort
+ #content
+ block body
+ script(type='text/template')#job-template
+ include _job
+ script(type='text/template')#row-template
+ include _row
#error
View
2  package.json
@@ -6,7 +6,7 @@
, "author": "TJ Holowaychuk <tj@learnboost.com>"
, "dependencies": {
"redis": "0.7.2"
- , "express": "2.5.11"
+ , "express": "3.0.0rc5"
, "jade": "0.26.3"
, "stylus": "0.27.2"
, "nib": "0.5.0"
Something went wrong with that request. Please try again.