Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Fix component.json to build use in component.io #581

Closed
wants to merge 5 commits into from

1 participant

@niclupien

It looked like the component.json file was outdated and I wasn't able to use socket.io-client as a component. This fix makes it works again.

This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Oct 21, 2013
  1. @niclupien

    Update component.json

    niclupien authored
  2. @niclupien

    Update component.json

    niclupien authored
  3. @niclupien

    Update component.json

    niclupien authored
  4. @niclupien

    Update component.json

    niclupien authored
  5. @niclupien

    Update component.json

    niclupien authored
This page is out of date. Refresh to see the latest.
Showing with 14 additions and 8 deletions.
  1. +14 −8 component.json
View
22 component.json
@@ -2,19 +2,25 @@
"name": "socket.io",
"version": "1.0.0",
"dependencies": {
- "learnboost/engine.io-client": "0.4.0",
- "learnboost/socket.io-protocol": "1.0.2",
- "component/emitter": "0.0.6",
- "component/bind": "0.0.1",
+ "learnboost/engine.io-client": "*",
+ "learnboost/socket.io-protocol": "*",
+ "component/emitter": "*",
+ "component/bind": "*",
"component/json-fallback": "*",
- "timoxley/to-array": "0.1.4",
- "visionmedia/debug": "*"
+ "timoxley/to-array": "*",
+ "visionmedia/debug": "*",
+ "component/url": "*",
+ "component/bind": "*",
+ "component/object": "*"
},
"scripts": [
"lib/index.js",
"lib/manager.js",
"lib/engine.js",
"lib/socket.js",
- "lib/emitter.js"
- ]
+ "lib/emitter.js",
+ "lib/url.js",
+ "lib/on.js"
+ ],
+ "main": "lib/index.js"
}
Something went wrong with that request. Please try again.