Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Release 0.7.7

  • Loading branch information...
commit c3fa1bf5af65484ddd4c0a25f58db6ddee3fb865 1 parent 8798cfb
@rauchg rauchg authored
Showing with 25 additions and 3 deletions.
  1. +22 −0 History.md
  2. +1 −1  lib/socket.io.js
  3. +2 −2 package.json
View
22 History.md
@@ -1,4 +1,26 @@
+0.7.7 / 2011-07-12
+==================
+
+ * Fixed double dispatch handling with emit to closed clients.
+ * Added test for emitting to closed clients to prevent regression.
+ * Fixed race condition in redis test.
+ * Changed Transport#end instrumentation.
+ * Leveraged $emit instead of emit internally.
+ * Made tests faster.
+ * Fixed double disconnect events.
+ * Fixed disconnect logic
+ * Simplified remote events handling in Socket.
+ * Increased testcase timeout.
+ * Fixed unknown room emitting (GH-291). [3rd-Eden]
+ * Fixed `address` in handshakeData. [3rd-Eden]
+ * Removed transports definition in chat example.
+ * Fixed room cleanup
+ * Fixed; make sure the client is cleaned up after booting.
+ * Make sure to mark the client as non-open if the connection is closed.
+ * Removed unneeded `buffer` declarations.
+ * Fixed; make sure to clear socket handlers and subscriptions upon transport close.
+
0.7.6 / 2011-06-30
==================
View
2  lib/socket.io.js
@@ -15,7 +15,7 @@ var client = require('socket.io-client');
* Version.
*/
-exports.version = '0.7.6';
+exports.version = '0.7.7';
/**
* Supported protocol version.
View
4 package.json
@@ -1,6 +1,6 @@
{
"name": "socket.io"
- , "version": "0.7.6"
+ , "version": "0.7.7"
, "description": "Real-time apps made cross-browser & easy with a WebSocket-like API"
, "homepage": "http://socket.io"
, "keywords": ["websocket", "socket", "realtime", "socket.io", "comet", "ajax"]
@@ -15,7 +15,7 @@
, "url": "https://github.com/LearnBoost/Socket.IO-node.git"
}
, "dependencies": {
- "socket.io-client": "0.7.3"
+ "socket.io-client": "0.7.4"
, "policyfile": "0.0.3"
, "redis": "0.6.0"
}
Please sign in to comment.
Something went wrong with that request. Please try again.